Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a problem with Split Line At Point and polygons which have been dissolved using arcpy.Dissolve_management.

When I try this model to get polygon contour split at some points.

arcpy.FeatureToLine_management("parcel" , "lim_parcel")
arcpy.Dissolve_management("lim_parcel", "lim_parcel_solv", "" , "", "SINGLE_PART", "DISSOLVE_LINES")
arcpy.SplitLineAtPoint_management("lim_parcel_solv", "point_parcel", "lim_parcel_solv_split" , "1" )

I always get a line split at one location where there is no point and the location of that unexpected split is the old vertex before polygon dissolve.

enter image description here

Any help please.

share|improve this question
    
Have to tried simplifying the geometry first before splitting? How is your point parcel being created? –  Jamie Jan 2 '13 at 16:39
    
i have tried to simplify the polygon with greater values, till it loses its red vertex but the unwanted vertex still present. the points have been pointed by the user, then the polygon have been built using these points. –  geogeek Jan 2 '13 at 17:32
1  
i know you may have tried this already, but RepairGeometry fixes a lot of unexplainable geometry errors. –  gotanuki Jan 3 '13 at 20:28
    
@gotanuki thanks , i tried it but without a result . –  geogeek Jan 3 '13 at 21:24
1  
the only way to feasibly approach this problem is to run through your procedure multiple times with multiple changes to parameters and verify if it is indeed an internal function error on the part of ArcGIS. if so, an email to ESRI is probably the only thing I can think of. –  gotanuki Jan 4 '13 at 21:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.