Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I know this question has been answered before, 3 months ago, but cannot work out how to join that thread.

I have been using Mt Lion with QGIS successfully for some weeks but now get the 'Cannot be opened..' message on attempting to start. I have reinstalled the GDAL framework Complete but without success.

Any suggestions most welcome!

TW

The core of the error message is:

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: Library not loaded: /Library/Frameworks/PROJ.framework/Versions/4/PROJ Referenced from: /Applications/QGIS.app/Contents/MacOS/QGIS Reason: Incompatible library version: QGIS requires version 8.0.0 or later, but PROJ provides version 7.0.0

share|improve this question
    
According to error message I think you need to update few libraries.. try to update the version OR reinstall I think it will help you and I am researching on your error message. –  Sunil Jan 2 '13 at 13:09
add comment

2 Answers 2

It looks like your Proj4 is out of date. Maybe try a complete uninstall and reinstall from the Kyng Chaos build:

http://www.kyngchaos.com/software/qgis

share|improve this answer
    
Uninstall & reinstall worked! Very many thanks. –  tedwalsh Jan 2 '13 at 17:18
add comment

I received the exact same error message. And I found that installing the newest PROJ framework was the only thing necessary to make QGIS work again. Deinstalling QGIS was not necessary.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.