Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When compiling mapfish I can't help but notice the quickstart instructions on the home site are not very good and have led to broken results so far. Any one able to clarify the steps? for instance when running the patch script should I save to any particular directory? the follow on command lines, should they be run in the same terminal window? as root? what are paths that need to be set on a debian system?

That and broken links and the use of $ and # in the scripts without background explanation of use in a terminal emulator and system specific intructions makes me wonder if mapfish is ready for prime time.

Thanks for any help

Here are the instructions

I can only post 2 hyperlinks

Usually if I can't build from instructions on a website it's because the documentation is not so hot, I'm not a CS major but I have a decent amount of linux experience.

Thanks Lewis

The problem is I've used both shells and I've pasted in the commands they supply (which include the # or $ symbol) I didn't use the symbol, just let the shell supply the character and the commands didn't correctly execute.

The python environment from running the download script does not have a clean way to exit the shell after the compile runs, has a bunch of > which looks like pico or some other text editor running off the shell. Makes sense as the download is text.

the (env) $ case is not returned on the next line as per the instruction set.

I've tried the virtual env as well and the problem always ends up being at the

$ source env/bin/activate

"install MapFish"

(env) $ pip install mapfish""

the first line when run does not lead to a (env) $ case being returned at the beginning of the line.

share|improve this question
$ is a normal user shell with limited rights, # is a root shell with full system access. the actual commands start after that symbol. Could you specify what you have tried so far and what exactly is not working? ("broken links?") I might be able to help. – 5chdn Jan 4 '13 at 13:32
What version of Debian do you have installed? Did you install the dependencies listed above in the orange box labelled "Note"? Do you have gcc installed? If not, I would also recommend you install build-essentials so you compile any pip packages that may need it. You can do it using: sudo apt-get install build-essentials – Jamie Jan 16 '13 at 16:56
I found that I needed to run the script in a shell in the directory of the python file that is downloaded and then it compiles just fine : ) "To install MapFish, download the installation script, and execute it from a terminal." N00b error : ) – lewis Jan 29 '13 at 15:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.