Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working with a map and instead of using the labels feature I chose to use text boxes because the labels were not where I wanted them to be. I set up all the text boxes and then added gridlines using the add grid feature and some of the text boxes appear above the grid lines and some of the text boxes are below the gridlines aka the there are lines right through my text box. I have noticed when I try and click on the above gridline text boxes I cannot get them to move or edit them at all but I can with the textboxes that are underneath the grid. I have tried to send all the text boxes to the front using the order option but that did nothing. I have also looked at all the properties under text boxes and grids.

share|improve this question
What software are you using? – Aaron Jan 7 '13 at 17:58
I am using ArcGIS v 10.0 – Cara Jan 7 '13 at 19:00

I would recommend using the Convert Labels to Annotation... command, here's how:

  1. Label your features (right click layer > Layer Properties > Labels)
  2. Right click the labeled layer in the table of contents > Convert Labels to Annotation... > Choose your preferences. I often store the annotation "in the map" and create annotation for "features in current extent". Select "Convert" when you're done.
  3. With the "select elements" cursor (i.e. black arrow) select a label you want to move and drag it wherever you want. That's it.

I think you'll find there's more control of labels using annotations, because you can combine advanced placement properties (i.e. within layer properties > Labels) with custom drag and drop functionality. For example, you can see in the attached image, I converted labels to annotation and dragged the center grid labels inward.

enter image description here

share|improve this answer
thank you, I have tried this several times and I could never get it to work, but now it worked. I always created annotation fro all features, maybe that was the hiccup. This still doesn't solve my layer order problem however, do you know how to make the annotation the uppermost layer so that a grid is not visible over it – Cara Jan 7 '13 at 20:40
"Can annotation be drawn after (in front of) grids and graticules?" would make a good new question - but perhaps check whether it has been asked before first. – PolyGeo Jan 8 '13 at 0:00

Assuming you are working with ArcGIS it sounds like you are mixing labels/annotations with text boxes. Labels or annotations are part of the map and will appear below or behind objects added in layout view (like grids or text boxes).

If you just do everything with text boxes that should solve your problem.

share|improve this answer
I have been using strictly textboxes because the labeling/annotation function did not allow me to put the labels where I wanted them to be, and yes I am using ArcGIS v10.0 – Cara Jan 7 '13 at 19:00
Have you tried right clicking on the ones that are hidden, go to order, and selecting 'Bring to Front'? That should make sure they are the uppermost layer. Also, make sure you are adding your text boxes in layout view, not data view. – Kevin Jan 7 '13 at 20:07
yes I have tried that, any other suggestions – Cara Jan 7 '13 at 20:41
My only other thought would be to make the grid as a set of lines or polygons rather than use the Grid property of the data frame. That way you could have more control over the order that it is drawn in. – Kevin Jan 7 '13 at 21:06
Another workaround is to go store the grid as a graphic - which is an option when you create it. This will lock it down so it won't update if you adjust the zoom or pan of the map but any text that you add on top of it should be in front of the grid. I just toyed around with it for a bit and it seemed to work. – Kevin Jan 7 '13 at 22:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.