Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to access ESRI file gdb from Quantum GIS. I am on Windows 7, 64-bit. I have found many useful threads on how to set up this functionality within Quantum GIS. The method I went for is described in this thread. I installed QGIS as part of the OSGeo4W package. I went for an 'Advanced' installation and added QGIS (v.1.8.0) + 'gdal-filegdb:OGR File GDB Driver' library. This has been installed with no issues. In QGIS, when I navigate to 'Add vector layer' window and choose File GDB as source type, I am able to preview contents of the file gdb in the following 'Select vector layers to add' window. Upon making my selection I can see the layer being displayed in table of contents, however after a short while qgis is crashing. I have attached couple of screenshots of this process:

enter image description here enter image description here

Does anybody have similar experience or else can suggest solution to this issue? Do I need the ESRI File Geodatabase API installed as well to be able to access ESRI file GDB?

Many thanks, Magda

share|improve this question
    
the ESRI GDB was created in ESRI 9.3, 10 ? –  A.R Jan 8 '13 at 16:12
    
It was created using v. 10 –  Magda Jan 8 '13 at 16:13
    
Same issue here (and installation procedure). Tried on FileGDB's that were either upgraded to 10.0 from 9.3 or were built from scratch. When adding a layer from the upgraded GDB, QGIS just crashes. You can add a layer from the GDB created from scratch, but doing anything else (panning, zooming, open attribute table) causes QGIS to crash. –  SaultDon Jan 8 '13 at 20:53
    
I can not even get to the stage of panning or zooming as it crashes straight after adding a layer in.. –  Magda Jan 9 '13 at 10:05
add comment

1 Answer 1

As shown under your menu on QGIS: HELP>ABOUT>, what version of GDAL/OGR is your QGIS compiled against? Is that 1.9.2?

share|improve this answer
1  
FileGDB is only working for GDAL 1.9.0 and will probably need to get upgraded for 1.9.2 hub.qgis.org/issues/7011 –  SaultDon Jan 19 '13 at 2:03
    
My QGIS is compiled against v.1.9.2 GDAL/OGR. IS there a way to run QGIS with GDAL 1.9.0 at the moment? –  Magda Jan 21 '13 at 11:07
    
@SaultDon This issue was closed, cause it's a OSGEO4W-issue trac.osgeo.org/osgeo4w/ticket/309 . This issue was already closed as fixed 8 weeks ago, but from reading it, i can't find a hint what ordinary users can do when still facing problems. –  Bernd V. Mar 18 '13 at 9:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.