Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Possible Duplicate:
How to fix QGIS error “Entry Point could not be located”?

I have a problem with QGIS 1.8.0 Lisboa installed on a desktop with Windows 8 Pro. When I launch qgis.bat the message "The procedure entry point ?minimum@QAbstractSlider@@QBEHXZ could not be located in the dynamic link library C:\Progra~2\Quantum GIS Lisboa\bin\phonon4.dll" appears.

I would like to precise that when I installed QGIS 1.8 for the first time it ran correctly.

I think that some Windows update or new software installations caused the problem.

If I try to re-install QGIS nothing changes.

Is there a possibility to restore the situation?

Thank you, have a nice day

share|improve this question

marked as duplicate by whuber Jan 10 '13 at 14:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

It's always a good idea to install QGIS in a folder without blanks. The OSGeo4W installer does this by default, the standalone does not. The default C:\Programs (x86)\Quantum GIS Lisboa\ spoils some parts of the installation.

And please use a fresh version of OSGeo4w setup.exe, because older versions were also broken.

share|improve this answer
    
I tried with your suggestions, but the result is the same –  Massimo Calosi Jan 10 '13 at 12:03
1  
Ok, but the path in the error message should be different. Is the dll there? Try copying it to \apps\qgis\bin. Furthermore, search your hard disk for dlls of that name. Maybe another version is interfering. The right one should be from Feb 2011. –  Andre Joost Jan 10 '13 at 12:53
    
Solved! I copied all files in \OSGeo4W\bin\ to \OSGeo4W\apps\qgis\bin\. At first time I moved only phonon4.dll: then, launching qgis.bat a new error appeared (qwt5.dll missing). I found another post regarding this problem (gis.stackexchange.com/questions/31038/…) and I fixed the problem. Now QGIS seems working fine! Thanks –  Massimo Calosi Jan 10 '13 at 13:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.