Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was given ArcMap toolbar and tool engine files without instructions on how to install but the code was done by someone else and it should work. How do I install it in ArcMap 10? I attempted to add the tool by going to customize->toolbar->customize->new and add files, but it wouldn't take the dll files in my directory. Is there another file type it is supposed to take? Or do I need to go through some kind of workaround in VS? I haven't installed ArcMap dev on my version of VS.

share|improve this question
Try adding the .tlb file if there is one. Otherwise, use ESRIRegAsm. – blah238 Jan 10 '13 at 19:48
ok, so I was able to add the tlb file and it gave me an added a list of stuff successfully message, but no icons are coming up, and no text as well. I think I'm supposed to add the GUI details somehow? – Carl Carlson Jan 10 '13 at 20:18
They will not pop up automatically. Instead use the Customize-Toolbar menu to toggle Toolbars or use the Customize dialog to add toolbars or commands. Commands will show up in various categories or you can search for them by name. – blah238 Jan 10 '13 at 20:51
right well I forgot to add that I had the checkbox toggled for the tool, but the tlb file I added was from the toolbar tlb file, do I need to configure that with the engine folder? Because where the tool is supposed to be, it is a blank space with no listeners. I actually tried to use the ESRIRegAsm, but I'm not sure what the assembly path would be or where the native com server dll is. – Carl Carlson Jan 10 '13 at 21:03
I tried the Customize dialog, but the tools that were supposed to be part of the toolbar were not visible. – Carl Carlson Jan 10 '13 at 21:06

Well, when I developed a toolbar in C# I always install trough DOS using the command lines window (it is in accesories file), and it always works.. you must only consider to use the command window as Administrator this is important...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.