Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

As the title says, my layers will show up blurry on top of any of the Google Maps base layers, but not on top of OpenStreetMap. I am using OpenLayers 2.12.

See the screenshots attached below:

GMAPS

OSM

share|improve this question
1  
Looks like 2 different zoom levels and the line is thicker on the top one. Is this a line or a polygon? Overall looks "fine" to me on both. And is the top one Google API on it's own, or Google via OpenLayers? –  Vadim Jan 11 '13 at 5:17
    
may be we need to see some code? and the site? –  iant Jan 11 '13 at 7:23
    
Further to Vadim's and iant's comments, can you also make the data available? At least a representative sample? –  BradHards Jan 11 '13 at 9:02

1 Answer 1

up vote 2 down vote accepted

Until you get a chance to update your question, it may be that you are displaying a cached service in epsg 4326, and in the openlayers map with the projection set to 4326, then it appears fuzzy in google maps when being displayed in googles default spherical mercator projection.

share|improve this answer
    
So obvious it was difficult to notice. Definitely a mix up with projections. Fixed. Thank you. –  Michael Markieta Feb 23 '13 at 8:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.