Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

i am having some issues when using the Geoserver Web Mapping Service to display GeoTIFF-Files. When zooming out (in an OpenLayers-Client or in the Geoserver Layer Preview for instance) the quality seems to be very poor. When opening the GeoTIFF in a picture viewer the quality seems to be ok

screen shot

I am working on a project where i have to display very old maps in an webbased application, so the quality is quite important. I have alredy tried to alter the compression levels of the wms in Geoserver, in vain.

I'd be grateful if somebody could come up with a hint or an advise. Thank you.!

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Add overviews to your image using gdaladdo, using -r average. Your viewer is probably building an image pyramid in memory or on disk, creating the same effect as persistent overviews.

share|improve this answer
    
Hi Andrea, thank you very much for your response. Adding an overview to my GeoTiff files was exactly what I have been looking for. –  user14157 Jan 16 '13 at 16:20
    
Just for the record: I used the GDAL library in QGIS (I'm quite sure it works somewhere else too) in order to create an overview: Raster --> Other --> Create Overview. Than i used the settings suggested above. The overview is than added directly to the geotiff and makes it about 1/3 bigger. Well now everything looks great. –  user14157 Jan 16 '13 at 16:28
add comment

Your picture viewer uses a different resampling method. In GeoServer you can change the default interpolation from the default nearest neighbor interpolation to bilinear or bicubic: http://docs.geoserver.org/stable/en/user/webadmin/services/WMS.html

Be aware that bilinear and bicubic interpolations require more resources.

share|improve this answer
    
Hi and thanks for your quick response. When using another interpolation method than nearest neighbour i receive an even worse outcome. Is there any other way to improve the quality? Maybe by using some special tile settings. Any help is highly appreciated. –  user14157 Jan 11 '13 at 13:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.