Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I just installed a brand new copy of QGIS 1.8 Lisboa and all of the associated software on a Windows Vista PC using the Windows Osgeo4W QGIS installer, and I get this message:

"The Plugin Installer has detected an obsolete plugin which masks a newer version shipped with this QGIS version. This is likely due to files associated with a previous installation of QGIS. Please use the Plugin Installer to remove that older plugin in order to unmask the newer version shipped with this copy of QGIS."

I did have an older copy of QGIS but I uninstalled it and I am 99% certain that I successfully deleted all of the associated files and directories. I notice that the Osgeo4W directories created by the OSGEO4W installer include several versions of QGIS (including 1.0 and 1.4), but I am a novice user and don't know how to figure out which plugin is causing trouble, or if this could be a bug in the Osgeo4w installer.

Thanks!

share|improve this question
    
I think the error window title used to contain some information on the plugin causing such trouble. Have you checked? –  underdark Jan 12 '13 at 11:39

1 Answer 1

You have to remove the .qgis folder in your user path. Thats where the plugins are stored.

share|improve this answer
1  
Well that is if you want to remove everything but a bit brute force to remove everything if it's just one plugin. Also if you do this only delete the \python\plugins folder –  Nathan W Jan 12 '13 at 6:43
    
Thank you both -- is there any way to tell which plugin is obsolete? –  John Jan 12 '13 at 6:56
    
Does Plugins -> Fetch Python Plugins... show a list that tells you what is installed? Does anything have status "invalid"? –  BradHards Jan 12 '13 at 7:14
    
Thanks BradHards, and apologies for the delayed response -- was away for a couple of days. I just tried that and there is a plugin called "Plugin Installer" that is upgradeable from 1.0.1.0->1.1, but when I try to upgrade I get the message "Failed to unzip the plugin package. Probably it's broken or missing from the repository." –  John Jan 16 '13 at 4:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.