Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

The title's it, really.

With .TAB file reader, you can add multiple layers to the reader and use the 'merge feature type' check box with an '*' to read all the layers listed in the source files, which can then be separated out again on featuretype name.

With the SQL Server Spatial reader, you can specify many layers in the database selection, but it seems that the 'merge feature type' option doesn't work.

Is this a bug, or expected behavior, or am I missing something?

EDIT: I have found that I can do this sometimes... so the above may be incorrect. I'll need to test some more.

share|improve this question
1  
Use the FeatureMerger or Joiner - details on how and when to use them evangelism.safe.com/fmeevangelist79 –  Mapperz Jan 15 '13 at 4:23
    
Nono, I don't want to merge the features together. Just read them all in with one reader to simplify the workspace. The joiner reads attributes from another source and appends then to features, while the featuremerger does the same with already read features. I just want more than one feature type in one reader. –  alexgleith Jan 15 '13 at 4:27
    
I think it works the same, the only difference is you have to specify the Feature Types to Read parameter. –  blah238 Jan 15 '13 at 9:03
    
FME will read any features and convert on the fly to .ffs (it's own bespoke format) regardless of format. Database Connections require to be separate. –  Mapperz Jan 15 '13 at 15:41
add comment

1 Answer 1

It does work for me - using a PostGIS database. I made a short video to demonstrate the process, just in case something isn't clear.

http://screencast.com/t/Se11qWtWc58C

By checking the dynamic option, all I'm doing is setting "feature types to read". But, as someone else mentioned, you do need to ensure the Feature Types to Read parameter includes your required tables (or is empty and so reads all of them).

If you still can't get it to work, I suggest contacting the Safe support team at http://www.safe.com/supportrequest

share|improve this answer
1  
The FME Evangelist! Congrats on the 2013 release. Confirmed on grouping by the "fme_feature_type" - I just tried with Oracle Spatial, and without grouping, the output was very trashy. Once enabled, it output as expected. –  Mintx Jan 15 '13 at 20:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.