Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a copy of the same folder on two (separate) network drives. I'm using a dataset iterator in a model to collect all the paths of files containing *_road*. There are a few dozen files in the folder, and a few subfolders as well.

Drive #1 is managed by my department, so we all have direct access to it, as far as the IT dept is concerned it does not exist (though it does bother them). Drive #2 is the main drive where everybody puts their work and is strictly controlled by IT.

When I run the the model on the folder on Drive #1, it appears to be executing nothing for ten minutes (just shows the processing dialog) and only the iterator appears to be executing once. It then speeds through the rest of the execution, collects the values and gives me the result. It's a bit weird, but it's fine as it gives me my result.

Running the model on Drive #2 gives very inconsistent results. At first, I had my file extensions limited to CAD only, but that crashed ArcCatalog after hanging for 15 minutes. I then took all the restrictions off, even my wildcard, so I could just get a multivalue of all the files in the folder. I ran the model in this form 4 times (twice in the morning, when few people are here, once at midday and once in the afternoon).

The results were inconsistent. Twice it simply crashed after 15 minutes, and twice it hung for 10 minutes, iterated through the folder but did not advance to Collect Values so it just ended the execution.

What I would like to know is:

Is going through the security on Drive #2 would be enough to impact the performance of the (basic) model, as I'm assuming for each iteration it would have to get through it?

Update: I've now created a small folder containing 4 CAD files, and a subfolder with 1 CAD file on my C drive. I then restricted the iterator to only look at CAD files as that is what my final model will have to do. To my surprise, it ran for about a minute, then ending the execution without collecting values, as if it didn't find the CAD files (which are the only files in the folder). When I run it without the restriction of only CAD files, it finds them. This seems to be a separate issue now.

share|improve this question
    
If you copy the same folder to a local hard drive and run it from there does it work consistently? –  blah238 Jan 16 '13 at 5:14
    
@blah238 yes, I almost never have problems if the data is on my C drive. That defeats the purpose of having the data on a network drive though. As it is, it took me an hour and a half to copy the 21GB folder from Drive #2 to Drive #1. We are trying to keep all data off our computers and trying to work solely on Drive #1, but if the network connection drops (which it does, often, and always when we have deadlines) it is impossible to get any work done at all. –  Cindy Williams Jan 16 '13 at 5:25
    
I would say this has less to do with network security and more to do with network performance. If you say the network connection drops often, that could be a cause of the crash. But I'm not a network specialist. When your model crashes, do you still have access to your network drives? Perhaps you could have your IT department run some connectivity tests to check if there is a problem. –  Fezter Jan 16 '13 at 6:31
    
Could you try running the model on a smaller folder? –  Fezter Jan 16 '13 at 6:34
    
Another thought - Are there folders nested deep with long path names? I believe the limitation on Windows is still 255 characters for a file path. –  Fezter Jan 16 '13 at 6:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.