Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

My Grass gives me this error message, Grass_info_error(4816,1):'make' required. Please install 'make' first. This happens when I attempt to fetch an add-on (r.viewshed). What am I doing wrong? and what is 'make'? Thanks for helping for a Grass newbie. I'm running on Mac Snow Leopard if that makes any difference.

share|improve this question
1  
Install the Xcode developer tools and see this SO question as well. –  Luke Jan 18 '13 at 7:06
1  
Thanks for the Xcode suggestion, but as I have Snow Leopard I can only install Xcode 3.2.2, since 4 is only available through purchase for Snow. I'm still having problems with my attempts to install viewshed. This is the error message at the end of the installation dialog: lipo: can't figure out the architecture type of: /var/folder s/58/58wPfZLCFWut1S7Od7Fu7++++TI/-Tmp-//ccj6TYRt.out make: *** [OBJ.i386-apple-darwin11.4.0/main.o] Error 1 ERROR: Compilation failed, sorry. Please check above error messages. –  user14353 Jan 19 '13 at 5:53
add comment

1 Answer

You may install GRASS 7 in parallel, it contains r.viewshed (so, no need to install it as addon): http://grass.osgeo.org/download/software/mac-osx/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.