Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm very new to mint/linux/GRASS and have no clue how to deal with these errors. Can I just change the URL somewhere?

Here is the simplest reproducible command to produce a failure: sudo apt-get install mysql-client-core-5.5

Here is the output from my attempt to run/install grass:

mint@mint ~ $ grass
The program 'grass' is currently not installed. You can install it by typing:
sudo apt-get install grass-core
mint@mint ~ $ sudo apt-get install grass-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  gdal-bin libarmadillo3 libdap11 libdapclient3 libepsilon0 libfreexl1
  libgdal1 libgeos-3.3.3 libgeos-c1 libgfortran3 libhdf4-0-alt libhdf5-7
  liblapack3 libmysqlclient18 libnetcdfc7 libodbc1 libogdi3.2 libpq5 libproj0
  libspatialite3 libxerces-c28 mysql-common odbcinst odbcinst1debian2 proj-bin
  proj-data python-numpy
Suggested packages:
  python-gdal grass-doc grass-gui grass-dev e00compr avce00 gnuplot gpsbabel
  gpstrans netpbm python-rpy2 xml2 libhdf4-doc libhdf4-alt-dev hdf4-tools
  libnetcdf4 libmyodbc odbc-postgresql tdsodbc unixodbc-bin ogdi-bin
  proj-ps-doc python-numpy-doc python-numpy-dbg python-nose python-dev
  gfortran
The following NEW packages will be installed:
  gdal-bin grass-core libarmadillo3 libdap11 libdapclient3 libepsilon0
  libfreexl1 libgdal1 libgeos-3.3.3 libgeos-c1 libgfortran3 libhdf4-0-alt
  libhdf5-7 liblapack3 libmysqlclient18 libnetcdfc7 libodbc1 libogdi3.2 libpq5
  libproj0 libspatialite3 libxerces-c28 mysql-common odbcinst odbcinst1debian2
  proj-bin proj-data python-numpy
0 upgraded, 28 newly installed, 0 to remove and 130 not upgraded.
Need to get 1,043 kB/33.6 MB of archives.
After this operation, 94.8 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Err http://archive.ubuntu.com/ubuntu/ quantal-updates/main mysql-common all 5.5.28-0ubuntu0.12.10.1
  404  Not Found [IP: 91.189.92.156 80]
Err http://archive.ubuntu.com/ubuntu/ quantal-updates/main libpq5 amd64 9.1.6-1ubuntu1
  404  Not Found [IP: 91.189.92.156 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-common all 5.5.28-0ubuntu0.12.10.1
  404  Not Found [IP: 91.189.92.200 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main libmysqlclient18 amd64 5.5.28-0ubuntu0.12.10.1
  404  Not Found [IP: 91.189.92.200 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5.5.28-0ubuntu0.12.10.1_all.deb  404  Not Found [IP: 91.189.92.200 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.28-0ubuntu0.12.10.1_amd64.deb  404  Not Found [IP: 91.189.92.200 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/postgresql-9.1/libpq5_9.1.6-1ubuntu1_amd64.deb  404  Not Found [IP: 91.189.92.156 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
mint@mint ~ $ 
share|improve this question
    
sudo apt-get update<br/> sudo apt-get upgrade –  ca0v Jan 19 '13 at 4:25
add comment

1 Answer

up vote 1 down vote accepted

Had to update my package definitions and upgrade my packages:

sudo apt-get update
sudo apt-get upgrade
share|improve this answer
1  
Please accept the answer if correct, even if it was written by yourself. Thanks. –  markusN Jan 19 '13 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.