Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I've installed gdal using the brew utility on OS X so the proj and geos dependencies were also installed. I'm now trying to warp a GeoTIFF so that I can import it into Google Earth. I am getting a proj error, and cannot figure out how to solve it.

I use the following command:

gdalwarp -t_srs "EPSG:4326" in.tif out.tif

and get the following error message:

Processing input file in.tif. 
ERROR 1: No PROJ.4 translation for source SRS, coordinate transformation initialization has failed.
0...10...20...30...40...50...60...70...80...90...100 - done.

There is very little on Google about this error.

I have set my GDAL_DATA and PROJ_LIB environment variables to /usr/local/shar/gdal and /usr/local/share/proj respectively.

I do not think this is a problem with the input file since it appears to have a coordinate system defined already, checked with gdalinfo:

Driver: GTiff/GeoTIFF
Files: in.tif
       in.tfw
Size is 341, 558
Coordinate System is:
LOCAL_CS["WGS 84 / Antarctic Polar Stereographic",
    UNIT["metre",1,
        AUTHORITY["EPSG","9001"]]]
Origin = (-3143782.158253818750381,3005869.481321755331010)
Pixel Size = (6268.758042377240599,-6268.758042377240599)
Metadata:
  AREA_OR_POINT=Area
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  (-3143782.158, 3005869.481) 
Lower Left  (-3143782.158, -492097.506) 
Upper Right (-1006135.666, 3005869.481) 
Lower Right (-1006135.666, -492097.506) 
Center      (-2074958.912, 1256885.987) 
share|improve this question
    
Can you make the source file available? Also, can you try explicitly setting the source SRS, since that doesn't look like a "full" / "known" coordinate system in the gdalinfo - it would normally have PROJCS[] at the start. –  BradHards Jan 19 '13 at 3:25
    
The image (and TFW file) is here: dl.getdropbox.com/u/12453163/peninsula.zip. The suggestion to use EPS:3031 by @JayLaura worked! Thank you! –  mankoff Jan 19 '13 at 5:43
add comment

1 Answer

up vote 5 down vote accepted

Your source coordinate system is most likely not defined in the CVS file that GDAL searches for proj4 strings. It looks like you might be able to pass the source EPSG as 3031 (from spatialreference.org)

Note that it looks like your input is in a local projection. Is this clipped from a larger raster?

To explicitly define the source you could just provide the proj4 string. From the link above:

gdalwarp -s_srs '+proj=stere +lat_0=-90 +lat_ts=-71 +lon_0=0 +k=1 +x_0=0 +y_0=0 +ellps=WGS84 +datum=WGS84 +units=m +no_defs' -t_srs "EPSG:4326" in.tif out.tif

share|improve this answer
    
Setting -s_srs 'EPSG:3031' solved it. Thank you. Any advice how I would have found 3031 from the missing 9001? I don't see a connection. –  mankoff Jan 19 '13 at 5:44
    
I just did a search on spatialreference.org for "Antarctic Polar Stereographic". –  Jay Laura Jan 19 '13 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.