Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I applied the Vector>Geoverarbeitungswerkzeuge>Auflösen (Dissolve) on a zoning plan (see picture zoning plan). I used the attribute village name as the dissolving criteria. The resulting geometry for the village (yellow colored) is sprinkled with small polygons or also larger polygons are not dissolved (see picture sprinkled geometry). In the attribute table the information is in one row.

Are there any approaches to obviate this? Changing any settings? I am using QGIS 1.7.2-Wroclaw.

zoning plan

sprinkled geometry

share|improve this question
Well, what does the attribute table say after selection of those slivers? Most likely they have another attribute than the village name. Maybe another partial dissolve, the "Eliminate sliver polygons"-tool or manual selection and deletion will get rid of these. – Curlew Jan 19 '13 at 11:39
Looks like topological problems to me... – markusN Jan 21 '13 at 22:36

This is undoubtedly a topology problem with your data.

I would recommend updating to the latest version of QGIS, this currently being 2.8.2 and running the Topology Checker (go to "Vector" tab) on all vector datasets concerned before ever running Dissolve process. This will identify erroneous topology which will then need to be manually rectified before Dissolve.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.