Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to connect my network to a points layer with a threshold of 4500 meters. I have about 11000 or so entries in my polyline and about 24 in my points layer.

I have alreday used v.distance, hence the threshold. However I recieve an error (image attached) any time I try the following:

v.net input=network points=cdw1c output=network_v1 operation=connect threshold=4500

Here is the error: enter image description here

Error content is:

Assertion failed: !p->taken[i], file split_q.e, line 69

Can anyone help me to understand what it means?


Update:

After a long consulation with a generous user from GRASS community, I still havn't came to a solution. I've tried on two computers with WIN 7 as operation system, the following GRASS versions: 6.4.2 (through QGIS and without the plugin), 6.4.3 RCs, 7.0.0

For the first two I have received the same error, for version 7 I didn't recieve the error but the process have never finished. On the other hand, my helper managed to complete it in seconds using my files.

Can the problem have something to do with windows 7, some background or system process, or so? Should I install any extention or plugin in order to run network analysis programs on win 7?

Thanks a lot in advance.

Dor

share|improve this question
add comment

2 Answers 2

Well I don't have a verified answer for this. However after few days of hard work, consultation with other GRASS-users via the community mailing lists, and help from the members of this forum, I came to a conclusion that there is a problem running v.net on windows.

I solved it by installing Linux-mint 14 on my computer. I run GRASS-gis using the new OS and it worked like a charm. I attach a link to another question, in which some users here kindly explained to me how to install GRASS on Linux.

share|improve this answer
add comment

For the record: the problem cannot be solved in GRASS 6 for Windows7 (see https://trac.osgeo.org/grass/ticket/1855#comment:3).

But it is working fine in GRASS 7 which will be released this year. To work with it right away, nightly snapshots for Windows are available here: http://wingrass.fsv.cvut.cz/grass70/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.