Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Due some network issue (Maps are not displaying in secure environment), I want to change the default port 6080 to 8080. I am going through Web help and few links in which they mentioned that install ArcGIS web adopter but I do not think that it is recommend for Amazon instance.

We have our ArcGIS Server 10.1 on Amazon instance (windows environment) and I am using the REST link in my Java script applications & sometimes the ArcGIS Port 6080 is blocked due to network permissions and hence my maps are not visible that’s why I need 8080 port

Here are the links I am going through…

Ports used by ArcGIS Server http://resources.arcgis.com/en/help/main/10.1/index.html#/Ports_used_by_ArcGIS_Server/015400000537000000/

Deployment scenarios http://resources.arcgis.com/en/help/main/10.1/index.html#//015400000488000000

Amazon configuration for ArcGIS Server 10.1 http://hackgeo.com/arcgis/arcgis-server/arcgis-server-10-1/arcgis-server-10-1-on-ec2-single-server-initial-setup

So any workarounds/suggestions will be great : )

Thank you in advance!!

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

From the Esri documentation:

Q. How do I change ArcGIS Server to use a port other than 6080 and a site name other than arcgis?

A. The recommended way to expose your web services through a different port and site name is to install the ArcGIS Web Adaptor.

If you want to not do what Esri recommend (which could also void your support agreement) you can open this file:

C:\Program Files\ArcGIS\Server\framework\runtime\tomcat\conf\server.xml

And change the port info within the following tag:

<Connector maxHttpHeaderSize="65535" connectionTimeout="20000" **port="6080"** protocol="HTTP/1.1" maxPostSize="10485760" redirectPort="6443" server=" "/>

I would not do this, as you might get some unexpected behaviour elsewhere.

I would recommend hitting the Elastic IP as opposed to the specific instance name and port number. Assuming your internal issues are around HTTP on any other port than 80, the Elastic IP will solve this issue.

share|improve this answer
    
thanks for the quick reply. I will check above settings with my IT admin and let you know soon thanks : ) –  Sunil Jan 21 '13 at 7:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.