Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm displaying several point shapefiles. I want them all labeled with the field "ident" which is a 3 digit number starting at 001. Two of the three shapefiles show the labels correctly but the 3rd one shows a double label for each point. Instead of just saying "027" it says "027027". In the Layer properties window, I tried unchecking the box that says "Label features in this layer" but this removes the labels completely, then when I recheck "Label features" in the menu that comes when I right click the layer in the table of contents, the double layers re-appear.

Any suggestions would be much appreciated!

Molly

share|improve this question
2  
Have you checked the attributes of the third layer to make sure they're actually triple digits? Also, could the layers contain duplicate data? –  dassouki Jan 5 '11 at 16:12
    
I agree with dassouki, duplicate data may be the culprit. –  Zachary Jan 5 '11 at 16:38
    
this is very clear to say that the Single Label for the Multiple Points - thanks alot for providing the solution- thanks & regards Edla Anil –  Edla Anil Apr 11 at 23:30
    
Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. –  BradHards Apr 12 at 0:48
add comment

5 Answers

You don't say wether the 'ident' field for the 3rd shapefile contains the double problem in the attribute table. If it does then you could manipulate the shapefile's associated DBF in excel using the 'text to columns' feature to get rid of the extra digits. Hope this helps.

Damien

share|improve this answer
    
Thanks for your response. No, I checked the attribute table, and the ident field is as it should be with just 3 digits. –  Molly Hale Jan 5 '11 at 16:27
add comment

You might check your label expressions to see if some reason it has set it to [ident][ident]. I'm not sure how this would be turned on.

Hope that helps, David

share|improve this answer
    
That could possible be it too. and sometimes, if you selection as layer, it could mess up the labeling as well –  dassouki Jan 5 '11 at 17:54
    
No, the label expression just reads [IDENT]. –  Molly Hale Jan 5 '11 at 19:53
    
Dassouki, I'm not clear what you mean by "if you selection as layer". Could you please clarify what you mean? Thanks, Molly –  Molly Hale Jan 5 '11 at 19:56
add comment

Have you confirmed that there are not stacked points located in the third layer? If you have 2 points that are exactly in the same location and then default label them (both), you will end up with 2 labels that are labeled in the upper left and upper right, but looks like the text is being duplicated from one label point.

In the example below, you can see that 2020 & 2023 are single points and single labels. 2011 & 5367 are 2 points stacked perfectly on top of each other and therefore give the look that you describe. 2008 & 5355 shows a good example of "nearly stacked" points and labels that, if you zoomed out far enough, would eventually look like they were "stacked" and would eventually give you the "double label" effect.

To fix this, you would either need to eliminate the stacked points, or you could play with "Buffer" setting on the "Conflict Detection" tab of the label "Placement Properties" (this works is 9.3, not sure if the 10 dialog is the same).

alt text

share|improve this answer
    
Ryan, Thank you! This WAS the problem. Somehow I had the points duplicated within the shapefile. I reloaded them with DNR Garmin and now everything's groovy! Thanks also to everyone who made a suggestion. I really appreciate it. –  Molly Hale Jan 5 '11 at 22:44
1  
Your welcome, glad it was the solution. Don't forget to hit the little "checkmark" on this answer to close this question out. –  RyanDalton Jan 5 '11 at 22:59
add comment

I had a similar problem recently with just a few of my points.

It came down to the fact that I had excel open and while copy pasting from a cell to my attribute field.

If I didn't double click and select the text. (in other words if I just single clicked in a cell and didn't see the text selected [just an outline around the cell]).

Then in arcgis after pasting it looked correct in the attribute value.

However each time you label it shows it twice.

When you select it from arcmap and paste it into notepad you could then see "thestring[]thestring".

Very weird and hard to find. but it was an easy fix.

share|improve this answer
add comment

If this doesn't work for everyone there might be another cause: I had stupidly pasted a label twice into an attribute table cell (but it was only visible there once) and it labeled twice on the map. I only figured it out when I realized other fields labeled properly. Doh.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.