Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm trying to figure out an error in GRASS network analysis, for several days now. I started to suspect that it has something to do with my OS, namely Windows 7. Hence I installed Linux-Mint 14 (Nadia) on my computer. I would like to run GRASS 6.4 (or latest) on Linux to test the function, yet can't figure out how to do so.

Can someone help me with it? or direct me to some where on the web where it is explained?

Please advice,

Dor

share|improve this question
1  
community.linuxmint.com/software/view/grass - Then click install. Looks like Mint manages everything from there. –  Jay Laura Jan 22 '13 at 2:25
    
@JayLaura You might want to post that as an answer ;-) –  R.K. Jan 22 '13 at 2:29
    
@R.K. Done - it just felt like fishing for votes... –  Jay Laura Jan 22 '13 at 2:34
    
What is? Isn't that how we reward good answers around here? –  R.K. Jan 22 '13 at 2:37
    
thanks for all helpful and detailed answers. I hope it will also solve my net analysis problem in grass –  dof1985 Jan 22 '13 at 8:27
add comment

3 Answers 3

up vote 5 down vote accepted

It appears that mint is able to handle package installation via a web embeddable trigger.

Navigate to community.linuxmint.com/software/view/grass and click install.

Looks like Mint manages everything from there.

share|improve this answer
    
Hope the packagers will update to the current stable version soon... –  markusN Jan 22 '13 at 9:50
add comment

You open your package manager. Type grass. Hit the install button. It should be able to identify any dependencies you may not have and install those as well. A package manager usually comes with a Linux installation. Some are better than others. I like synaptic.

share|improve this answer
add comment

Package management in Mint Linux is based on apt: http://wiki.debian.org/Apt, which means that the following, typed into your terminal, should install GRASS:

sudo apt-get install grass

Once the package is installed, you should be able to launch it by typing

grass

into your terminal.

This will get you the latest stable version of GRASS. If you want something newer, you'll have to download and compile the source code: http://trac.osgeo.org/grass/wiki/DownloadSource; however, that is generally only recommended for advanced users who are willing to accept the tradeoff of potential instability & bugs to try out the latest and greatest version.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.