Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

We're using ArcGis 10.1 with ArcSDE 9.3.1 on Oracle 10g.

I've got 2 layers that cannot be opened or modified with ArcCatalog or ArcMap (but they show up in the list. Everything worked just fine until a few days ago when I added some columns from a third party software using SQL. As if this wasn't foolish enough (as it seems on Google) I also had an mxd open with these layers in it.

Now I cant open or use them in any ArcEnviroment of any kind (Also tried Topocad and FME, and on different computers, one of them has ArcGis 9.3.1... No go). Mostly I only get "Error opening feature class". Sometimes when I try to open the properties of the layers I get "Failed to edit the selected object(s). The workspace is not connected. Table attachments not supported in this release of the Geodatabase.". I've also gotten "Arcobjects error -2147216117 - Network I/O error".

The third party application however, can open and use them just fine, although it's reading from a view consisting of the data table + geometry table (the "F**"-tables) for each respective layer. With this in mind I've checked the database. Both the data tables and geometry tables exist with no errors and the connection between them is registered. I read somewhere on Google that the SDE.COLUMN_REGISTRY table could get out of sync when adding columns via SQL. So I checked it, but it's in sync. I also checked some metadata tables but could'nt see anything there (I don't really know what I'm looking for in there though).

My best guess is that the problem lies somewhere "between" ArcGis and the database, since the tables obviously exists and is working in the third party application. There's no network error either since the rest of the database layers and tables can be used just fine. I'm guessing the problem lies in some kind of registry, metadata tables or cache, but I'm getting all out of ideas.

edit: I forgot to mention that the tables are not versioned, and we tried a server reboot.

Anyone have any ideas?

Thanks for the help!

Martin

share|improve this question
    
Sounds like you've corrupted something by messing with the SDE system tables -- see if ESRI can help -- or restore from a backup. –  blah238 Jan 23 '13 at 12:59
    
Well, the problem started before I checked the system tables. And I only viewed them, didn't make any changes to them. So i didn't "mess" with them. If ArcMap didn't screw anything up, that is. –  Bananapa Jan 23 '13 at 13:03
    
What 3rd party application are you using? Knowing that might point to a pool of expertise. –  PolyGeo Feb 1 '13 at 8:45
    
It's a Swedish GIS application for water and sewage, called VA-banken –  Bananapa Feb 1 '13 at 9:03
    
Did you ever sort this out? What are the column types that were added? –  travis Mar 19 '13 at 16:40
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.