Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

Most of my layers in Qgis are shapefiles but I have some raster data which is terrain relief shadings that are GeoTIFFs.

In order to save a lot of time with the default colour and density that Qgis sets, I am trying to find out if there is some way I can set the colour and transparency all at once.

Simply put I want a colour (or rendertype) of singleband grey and a global transparency of 80% to be able to be applied all at once. I tried to set up a style for this but some of this information is not saved into the style.

share|improve this question
add comment

1 Answer 1

This is because when you save a project that has a raster with transparency the transparency doesn't get saved? I've noticed that too. One way round this is to overlay the hillshade raster with a large vector polygon and set its fill to white, then adjust the transparency of the polygon fill to get the hillshade looking right. Then add your vector layers on top of this. The transparency settings of the vector polygon layer will saved when you save the project. N.

share|improve this answer
    
A behavior like this (transparency settings not saved) should be reported as a bug. –  underdark Jan 27 '13 at 11:59
    
It's a known problem,see hub.qgis.org/issues/4953. Said to have been fixed in Master, but I haven't checked this. N. –  nhopton Jan 27 '13 at 12:33
    
No, what I am looking at is a way of saving the transparency into a style, so that I can apply that style to other rasters. –  kahukowhai Jan 30 '13 at 19:26
    
If saving the layer style as a *.qml file doesn't work I don't know what to suggest. Except for upgrading to Master that is, but there might be good reasons why you don't want to do this. –  nhopton Jan 30 '13 at 19:57
    
If you go to the style page, transparency is not part of the style of the layer. –  kahukowhai Feb 2 '13 at 2:05
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.