Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a composite address locator that was built using our streets line file and our address points that works great in ArcMap 10.1 sp1. But when published to ArcGIS Server (10.1 sp1) no results are ever returned, whether in a REST environment or within a map service. I've gone through the esri help files and it doesn't appear that I am doing anything wrong. (This is the first time I've ever published one out.) Has anyone else had this problem, and if so, how did you fix it? Is it due to it being a composite? As a side note, I did publish out the individual address locators and those too didn't work.

Thank you in advance

share|improve this question
    
is the 'Name locations added with tool using nearest address' enabled on the server? help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/… –  Mapperz Jan 28 '13 at 16:03
    
What version of ArcGIS Server? –  Kirk Kuykendall Jan 28 '13 at 16:31
1  
I'm using ArcGIS Server 10.1 sp1 (sorry I forgot to mention that) along with ArcMap 10.1 sp1. From what I can tell "Name locations added with tool using nearest address" appears to be for route finding only. –  Evan Jan 28 '13 at 20:51
add comment

4 Answers

up vote 3 down vote accepted

If you're publishing a composite locator to ArcGIS Server 10.1, I understand that this is always copied (regardless of datastore setup). The composite locator is just a pointer, so the copy time should be trivial. That said, I'd still setup a datastore folder entry for your locator. If the locator is on the Server, great, just reference the folder. If its not, share it as a UNC path and reference that. (though UNC takes a performance hit...thats another story). [or if its a small bunch of locators, maybe you want to copy them, again thats up to you]

Once you have it started, I'd suggest trying it in ArcMap as thats the easiest to consume (move to REST once you know it works). Either use the Geocode Addresses tool with the Locator Service as input, or use the Geocode toolbar and point the input locator at your Geocode Service. If this doesnt work, it should give you more information on why it isn't working. If it does work, then move to REST and try there. Just a guess but the REST input might not be correct, thus not getting any good output.

share|improve this answer
add comment

Khibma has it right - the composite locator file will be copied anyway to the server. This is the message you will get when analyzing the locator publishing either from ArcMap or from ArcCatalog.

I had problems publishing a composite locator myself but only when trying to publish a locator that is composed of a couple online geocode services (not your case, since you have only local data). One thing to try is to use ArcGIS Administrator API call (not sure if you have already tried that or you always use ArcGIS Desktop GUI for publishing).

  1. Copy the composite locator and all other participating locators to the ArcGIS Server computer
  2. Open your ArcGIS Server Administrator page (http://machinename:6080/arcgis/admin - if you use standard port) on the server computer and then log in using the admin username and the password.
  3. Click Services > createService
  4. Paste the code into the text box. You need to change "serviceName", "locator", and "locatorWorkspacePath"; ServiceName = name of your service that will be created, Locator = name of locator file on disk (without extention), LocatorWorkspacePath = location on disk on the ArcGIS Server machine where the locator file itself is stored (include geodatabase name if needed or just specify the folder).

{ "serviceName": "LocatorName", "type": "GeocodeServer", "description": "", "capabilities": "Geocode,ReverseGeocode", "clusterName": "default", "minInstancesPerNode": 1, "maxInstancesPerNode": 1, "instancesPerContainer": 1, "maxWaitTime": 60, "maxStartupTime": 300, "maxIdleTime": 1800, "maxUsageTime": 600, "loadBalancing": "ROUND_ROBIN", "isolationLevel": "HIGH", "configuredState": "STARTED", "recycleInterval": 24, "recycleStartTime": "00:00", "keepAliveInterval": 1800, "private": false, "isDefault": false, "maxUploadFileSize": 0, "allowedUploadFileTypes": "", "properties": { "outputDir": "C:\arcgisserver\directories\arcgisoutput", "virtualOutputDir": "/rest/directories/arcgisoutput", "locator": "LocatorFileName", "suggestedBatchSize": "1000", "minScale": "-1", "textAntialiasingMode": "Force", "antialiasingMode": "None", "maxScale": "-1", "maxResultSize": "500", "locatorWorkspacePath": "D:\Data\", "maxBatchSize": "1000" }, "extensions": [], "datasets": [] }

More information on ArcGIS Administrator API for publishing a service and setting its parameters.

share|improve this answer
add comment

If using 10.0, I would physically copy the locator files to the server and reference them there to create the service with ArcGIS Server Manager. In the parameter page for the service, you can browse for the locator file and you'll end up with a UNC path

\\YOUR_SERVER\ArcGIS\myproject\loc\

Also, always clear the cache after you make changes.

http://YOUR_SERVER/ArcGIS/rest/admin
  • Login
  • Clear Cache Options
  • Clear Cache Now
share|improve this answer
    
I'm using 10.1. The layout of creating a geocode has really changed with 10.1 (at least I think with 10.1, last time I probably did a geocode was in 9.2 or 9.3.) Everything is done wit ha UNC path name. –  Evan Jan 28 '13 at 20:53
    
Have you looked at the ArcGIS Server log? What does the fiddler response return? –  awesomo Jan 29 '13 at 17:59
add comment

You will also want to check the folder/path locations and the permissions assigned to them. If your place your data in a location for the supporting locators and the server does not have appropriate permissions then they won't be accessed.

Also, take a look at the settings you used to define your composite geocoder, make sure you have relative paths assigned and that those paths are also relative on your server, its possible that ArcGIS can't locate the underlying locators.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.