Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am stuck with installing a plugin for QGIS namend "Statist".

I get the following message when starting QGIS: "Missing matplotlib Python module". So basically this question relates to all plugins for QGIS using the matplotlib python module.

I have tried to stick to every advice on stackexchange in order to install the whole QGIS package on OS X correctly. However, I don't have any clue why QGIS cannot find the properly installed matplotlib /Library/Python/2.7/site-packages directory.

I installed matplotlib with sudo pip install matplotlib.

I know that some questions already relate to his problem, but none helped me with solving this problem. I appreciate every hint or workaround for this problem. Thank you.

J.


I use

  • OS X 10.7.4 QGIS 1.8.0-Lisboa
  • I've installed all necessary QGIS-related stuff from kyngchaos in the latest version.
  • QGIS had some problems with recognized rgdal first. I used the following advice – then it worked properly.

This is what i get when i check for all versions installed (while "USER" is my userdirectory):

import sys;sys.version;sys.path '2.7.1 (r271:86832, Aug 5 2011, 03:30:24) \n[GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)]' ['/Users/USER/.qgis/python/plugins/GeoCoding', '/Users/USER/.qgis//python/plugins/sextante', '/Users/USER/.qgis/python/plugins/GeoCoding', '/Applications/QGIS.app/Contents/MacOS/../Resources/python', '/Users/USER/.qgis//python', '/Users/USER/.qgis//python/plugins', '/Applications/QGIS.app/Contents/MacOS/../Resources/python/plugins', '/Library/Frameworks/SQLite3.framework/Versions/3/Python/2.7', '/Library/Python/2.7/site-packages/numpy-override', '/Library/Frameworks/GDAL.framework/Versions/1.9/Python/2.7/site-packages', '/Library/Python/2.7/site-packages/Scrapy-0.14.4-py2.7.egg', '/Library/Python/2.7/site-packages/lxml-2.3.4-py2.7-macosx-10.7-intel.egg', '/Library/Python/2.7/site-packages/w3lib-1.2-py2.7.egg', '/Library/Python/2.7/site-packages/readline-6.2.4.1-py2.7-macosx-10.7-intel.egg', '/Library/Python/2.7/site-packages/nose-1.2.1-py2.7.egg', '/Library/Python/2.7/site-packages/six-1.2.0-py2.7.egg', '/Library/Python/2.7/site-packages/pytz-2012j-py2.7.egg', '/Library/Python/2.7/site-packages/tornado-2.4.1-py2.7.egg', '/Library/Python/2.7/site-packages/pyzmq-2.2.0.1-py2.7-macosx-10.7-intel.egg', '/Library/Python/2.7/site-packages/pika-0.9.9-py2.7.egg', '/Library/Python/2.7/site-packages/Jinja2-2.6-py2.7.egg', '/Library/Python/2.7/site-packages/patsy-0.1.0-py2.7.egg', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python27.zip', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/plat-mac/lib-scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-old', '/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload', '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC', '/Library/Python/2.7/site-packages', '/Library/Python/2.7/site-packages/PIL', '/Users/USER/.qgis/python/plugins/mmqgis/forms', '/Users/USER/.qgis/python/plugins/QuickMultiAttributeEdit/forms', '/Applications/QGIS.app/Contents/Resources/python/plugins/fTools/tools']

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.