Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

My ArcGIS Server services are locking tables in SDE. This is a problem if I need to edit or overwrite them. Unfortunately the locks don't go away upon stopping the services. The only solution I have found is to restart the Linux arcsde service, which has many implications. Is there a better way to lose these phantom locks?

share|improve this question
add comment

3 Answers

up vote 8 down vote accepted

Tell ArcGIS Server not to make those locks.

In your service cfg files, add this:

<ServerObjectConfiguration>
...
    <Properties>
         ...
         <SchemaLockingEnabled>false</SchemaLockingEnabled>
    </Properties>
</ServerObjectConfiguration>

ESRI does not recommend this practice, but it should work for you. I did this for a bunch of really big services that required a massive (thousands of layers) data update while still running.

For more info, refer to the ESRI docs.

share|improve this answer
    
It worked! Restarting map services + SDE was not enough for the changes to take effect. I also had to restart AGS + IIS. (Not sure whether AGS or IIS was the problem, but I figure either one could be caching the XML content.) –  nw1 Jul 30 '10 at 14:56
add comment

At the UC ESRI was in fact recommending the use of the tag, so long as you carefully consider the "Use caution..." paragraph in the documentation.

share|improve this answer
add comment

Are spatially-enabled views an option? They've worked well for me in cases where I can't have a table locked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.