Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have problem with previewing layers in GeoServer. I installed Geoserver 2.2.4 (following instructions in manual) and everything was going well. I managed to login to it and create my own new workspace. I've created a new store and published that layer but when I try to preview that layer with openLayers all I see is empty map with no features on it. I've also tried with example on to see if the problem is with my shapefile but the same thing happens. I really don't know why because all I did was the same as it is written in manual. I hope somebody can help me with that. Thanks

share|improve this question
What about previewing in another format? Do you get output using GML or GeoJSON for example? – Jay Laura Jan 31 '13 at 19:20
No , same thing for all formats. But I found the problem. I will post it here as an answer now so other people could see it if they come to the same problem – user14026 Jan 31 '13 at 19:23
hi i tried also JRE6 environment and it didnt change anything again. Only 2.2 on my old xp computer is working. Please let me know which version is ok for set up geoserver on windows 7 ultimate? – user16213 Mar 15 '13 at 13:42
Hi, at the end I've installed Geoserver as a WAR in Apache Tomcat and I use windows 7 too. Maybe it's a little bit harder to configure it to work with apache but it's still easy and it could be very helpful later in your work. You can check this site to help you configure it. I hope that will help you. – user14026 Mar 15 '13 at 15:55

I found the problem now. The problem was obviously in the version of java runtime environment that I had installed. First I installed jre7 but now I uninstalled it and installed jre6 instead and now it works perfectly. I really can't understand what's the problem with jre7 but it looks like this is the only way to fix this problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.