Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have just been georeferencing a map on QGIS using British National Grid and it is not lining up with the vector maps I downloaded from OS. I used the 'From map canvas' option and used 'Linear' transformation. However, there appears to be a twist of a few degrees with the map and this suggests that the one is setting as grid north and the other magnetic which would explain the difference. I tried a few times with different reference points, but always the same result.

Anyone any ideas?

Ok, just to add. I rotated the original image by 1.5 degrees and then re-georeferenced and it near enough lined up. Surely the idea of georeferencing would be to put the points in the right place no matter what the orientation of the original raster map?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

When using a projected CRS (like EPSG:27700) QGIS doesn't know anything about true north or magnetic north I'm afraid. If the map image is rotated to start with (and most scans are) when you georeference it QGIS will rotate it to align with the OS Grid, which is what produces the black borders.

Hint: I don't know if you have discovered this but when georeferencing good, undistorted scans you only need two "calibration" points, one say in the bottom left of the image and the other in say the top right. Then set the georeferencer to use Helmert and Linear.

N.

share|improve this answer
    
As I mentioned below, I struggle to get good reference points form old maps, so anything that saves trying to locate them helps. –  Peter Cornelissen Feb 3 '13 at 14:26

Silly me :-( I should have checked before hand, I need to use Helmert transformation to get the orientation right. However, that has its own problem of leaving a big black area where the map is twisted on the main map. Will need to look at hat and ask another question if needed.

share|improve this answer
    
Make sure to use the 7-parameters for Helmert. The standard EPSG:27700 values stored in QGIS is only three-paramater, which leads to misalignment. The latest GDAL dev from gisinternals should already have the right transformation, or use the old GIS 1.7.4 Wroclaw. –  AndreJ Feb 3 '13 at 13:59
    
Thanks for the pointer. I will try to use as many points as possible, but sometimes on old maps (17th C for instance) it is difficult to find many reference points, I struggled on one to find 3. –  Peter Cornelissen Feb 3 '13 at 14:25
    
If you're using modern-day OS maps to find your GCPs you might find it easier to get these from Google Earth. There is something here that might help make life easier: wtp2.appspot.com/wheresthepath.htm –  nhopton Feb 3 '13 at 15:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.