Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a geoprocessing tool written in Python that contains operations on an XY event layer. It worked perfectly when running from ArcCatalog. When published as geoprocessing service on ArcGIS Server 10.1, however, it never worked. The JSON response when executed as REST service was

"error": {
  "code": 400,
  "message": "Unable to complete operation.",
  "details": [
   "Error executing tool.: ERROR 999999: Error executing function.\nThe XY event source name has not been setup correctly.\nFailed to execute (CopyFeatures).\n\nFailed to execute (NewCuringModelExpPy).\nFailed to execute (New_Curing_Model_ExpPy)."
  ]
 }

I have been struggling with this for days. Has anyone else ever come across this issue before or how was that solved?

Thanks!

Alex

share|improve this question
    
There seems to be a similar issue reported here but its 9.3 era so won't provide a step by step solution. –  PolyGeo Feb 6 '13 at 1:01
1  
I have had a data copy problem on 10.1. I haven't worked out the issue but have been suspect of 1. User priv on the arcgis folder. 2. Proper data folder registration in server –  Brad Nesom Feb 6 '13 at 4:03

1 Answer 1

I finally figured it out.

I had to change the database server name in connection properties from server alias to its IP address. Then it worked.

Thanks for all who post answers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.