Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a machine running OSGEOLIVE 6

Geoserver and most packages work without any issues but I can't get Geonetwork to run.

The ApplicationsGeoserversGeonetworkStart seems to work fine but then I get an unable to connect on localhost:8880/geonetworks/srv/en/main.home

The Geoserver is on localhost:8082 and I can login to it but can not get to the geonetwork home page.

Osgeo seems to have also installed tomcat in localhost8080 -i don't need this.

I tried the following as well

  1. Install Geonetwork2.8 beta (same issue with login to the home page). When I try sh start-geonetwork.sh I get a rm/mv error (see below)
  2. Install 2.4 using git clone instructions from geonetwork-opensource.org/download.html but I can't run the final command. See below.

Any ideas? I just want to open geoserver and geonetwork (also postgis)

best,

a@a-beta-osgeo:~$ cd master
a@a-beta-osgeo:~/master$ git checkout master
Already on 'master'
a@a-beta-osgeo:~/master$ git submodule update --init
Submodule 'docs' () registered for path 'docs'
Submodule 'gast' () registered for path 'gast'
Submodule 'geoserver' () registered for path 'geoserver'
Submodule 'installer' () registered for path 'installer'
Submodule 'maven_repo' () registered for path 'maven_repo'
Submodule 'release' () registered for path 'release'
Submodule 'web-itest/webspecs' () registered for path 'web-itest/webspecs'
a@a-beta-osgeo:~/master$ mvn clean install
The program 'mvn' can be found in the following packages:
 * maven
 * maven2
Try: sudo apt-get install <selected package>
a@a-beta-osgeo:~/master$ sudo mvn clean install
[sudo] password for atgis: 
Sorry, try again.
[sudo] password for atgis: 
sudo: mvn: command not found
a@a-beta-osgeo:~/master$ sudo apt-get install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 grass-dev : Depends: grass (= 6.4.3rc2-2~precise) but 6.4.2~upstream2-3~precise3 is installed
E: Unmet dependencies. Try using -f.
a@a-beta-osgeo:~/master$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libdapserver7 libdap-dev libxerces-c2-dev linux-headers-3.2.0-33-generic-pae
  libjasper-dev libgeos-dev linux-headers-3.2.0-33 libsqlite3-dev unixodbc-dev
  libmysqlclient-dev libpng12-dev libgif-dev libhdf5-serial-dev libfltk1.1
  libxml2-dev uuid-dev libpq-dev libgdal-dev libltdl-dev libspatialite-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  grass
Suggested packages:
  gpstrans
The following packages will be upgraded:
  grass
1 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.
1 not fully installed or removed.
Need to get 0 B/21.8 MB of archives.
After this operation, 53.7 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 212956 files and directories currently installed.)
Preparing to replace grass 6.4.2~upstream2-3~precise3 (using .../grass_6.4.3rc2-2~precise_i386.deb) ...
Unpacking replacement grass ...
Replacing files in old package grass-core ...
dpkg: error processing /var/cache/apt/archives/grass_6.4.3rc2-2~precise_i386.deb (--unpack):
 trying to overwrite '/usr/lib/grass64/bin/xganim', which is also in package grass-gui 6.4.2~upstream2-3~precise4
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/grass_6.4.3rc2-2~precise_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
a@a-beta-osgeo:~/master$ ^C
a@a-beta-osgeo:~/master$ 
share|improve this question

1 Answer 1

I've had the same issue. I have run sudo apt-get remove grass grass-dev libotb monteverdi which has then allowed me to be able to install and upgrade other software properly.

It seems that the reason for the issue is due to two versions of grass being installed.

share|improve this answer
    
Thanks...unfortunately I had to format and install Umbuntu and then just install geonetwork. So I have no way of checking if your answer works. Hopefully it will help others in the future. –  GeorgeC Feb 14 '13 at 5:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.