Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working with a polygon that is the result of a buffer and has a bunch of internal doughnut holes: Polygon with Holes What I want is this: enter image description here

I am using arcpy.EliminatePolygonParts_management() to fill in the holes but have a question about how this tool functions.

When I run the tool using the "PERCENT" condition I cannot get the holes to fill in. Initially I set the percent to 99 thinking that it would delete any part that was smaller than 99 percent of the total area of the polygon. That didn't work. Thinking that perhaps I had my logic backwards I set the percent to 1, that didn't work either.

I did get it to work, and produce a polygon that is just the outer boundary but to do so I had to switch to the AREA condition and set the number ridiculously (for my purposes) high, to 1 billion square meters.

I am quite confused by this... Can anyone offer an explanation to help clarify my understanding of how this tool works and why I can't get the "PERCENT" condition, which seems to be the more appropriate choice, to work?

share|improve this question

The interior 'features' you see are empty spaces. You can union with an extent polygon to get real features that can then be used in the eliminate tool. An alternate method is to convert the polygon to polyline, select the outermost polyline and convert back to polygon.

share|improve this answer
I understand all of that. My question is about what I am misunderstanding about using the Eliminate parts tool. – Kevin Feb 6 '13 at 17:42
You don't specify how large is the polygon. 1 billion square meters is less than an area that is 20 miles by 20 miles square. The likely answer is that you need to review the math for both percentage and area for your feature in question. – JLP Wisc. Feb 6 '13 at 21:19
Does the "PERCENT" option not work only when called using arcpy or have you tried it in the tool as well and that doesn't work either? Sometimes going back to the tried and true old tools might do the trick. Perhaps a bug report should be filed with Esri that can be corrected with the next service pack. – ccn Feb 7 '13 at 3:59
I've encountered this error when coming at if from arcpy and the ArcGIS tool. Regarding the matter of the area, the polygon in question is about 1,000,000 square meters, so specifying an area condition at 1 billion is actually a larger area than the total polygon area. – Kevin May 30 '13 at 14:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.