Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I just did a clean OS install and installed ActivePython 2.7.2

I want to use this Python install for use with ArcGIS 10.1

I just installed ArcGIS 10.1 and it did a new Python install.

What do I need to do to get Python for ArcGIS to install on my current Python?

share|improve this question
    
Does the ActivePython installation include numpy 1.6.1? If not, that may have been the problem. –  Cyrus Feb 8 '13 at 17:39
    
No, I guess it doesn't. Well it might, but I think it's a new version. I did figure it out though. Thanks. –  ian Feb 8 '13 at 18:08

2 Answers 2

up vote 2 down vote accepted

Alright, I figured out what was wrong. If you are using Python 2.7 and want ArcGIS to use your current Python install.

You need to download and install the following libraries before you install ArcGIS 10.1:

NumPy 1.6.1-

http://sourceforge.net/projects/numpy/files/NumPy/1.6.1/numpy-1.6.1-win32-superpack-python2.7.exe/download

Madplotlib 1.1.1-

http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-1.1.1/matplotlib-1.1.1.win32-py2.7.exe/download

If you do this, you will get a clean install.

share|improve this answer
    
This is documented in the help. I think only NumPy is required, but can't hurt to have matplotlib as well: resources.arcgis.com/en/help/install-guides/arcgis-desktop/10.1/… –  blah238 Feb 8 '13 at 18:31
    
Do you know if the same is true for when I installed the ArcGIS 10.1 SP1 Engine Background Geoprocessing? Will it also install into the same Python 2.7 I installed? –  ian Feb 8 '13 at 21:31
    
If you are talking about the 64-bit Background Geoprocessing install, this will install another, separate 64-bit version of Python. –  blah238 Feb 8 '13 at 22:41
    
Hmm, okay. That makes sense. Thank you. –  ian Feb 9 '13 at 1:36
    
Thanks for your answer. But what if I installed Python 2.7.6 after I had installed ArcGIS 10.1? I keep getting many errors in ArcMap because of this. Any solution to my problem would be much appreciated –  aelwan Apr 24 at 4:30

I am not sure if this will work, but you can try creating a new text file named Desktop10.1.pth with the following content in your ActivePython installation's Lib\site-packages folder:

C:\Program Files (x86)\ArcGIS\Desktop10.1\bin
C:\Program Files (x86)\ArcGIS\Desktop10.1\arcpy
C:\Program Files (x86)\ArcGIS\Desktop10.1\ArcToolbox\Scripts

(Assuming a standard installation on a 64-bit OS).

There may be more plumbing required which is why I would say to just let ArcGIS do its thing...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.