Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I tried to use the Raster (Extration) tool "clipper" and I always get this error log: What is my problem?

Fehler bei der Ausführung von Python-Code:

Traceback (most recent call last):
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\GdalTools.py", line 342, in doClipper
    self.runToolDialog( d )
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\GdalTools.py", line 370, in runToolDialog
    dlg.show_()
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\tools\doClipper.py", line 47, in show_
    BasePluginWidget.show_(self)
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\tools\widgetPluginBase.py", line 44, in show_
    self.onLayersChanged()
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\tools\doClipper.py", line 71, in onLayersChanged
    self.inSelector.setLayers( Utils.LayerRegistry.instance().getRasterLayers() )
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\tools\GdalTools_utils.py", line 161, in getRasterLayers
    return filter( self.isRaster, LayerRegistry.layers )
  File "C:/Dokumente und Einstellungen/user/.qgis//python/plugins\GdalTools\tools\GdalTools_utils.py", line 156, in isRaster
    if layer.usesProvider() and layer.providerKey() != 'gdal':
AttributeError: 'QgsRasterLayer' object has no attribute 'usesProvider'

Python-Version: 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]

QGIS-Version: 1.9.0-Master Master, 298f0c0

share|improve this question
    
Seems like the API changes have broken clipper. Try stable QGIS 1.8 instead. –  underdark Feb 15 '13 at 12:42
    
1.8 works. Why 1.9 not? –  Pimpel Feb 15 '13 at 12:45
1  
because of recent api-changes some plugins will suddenly report python errors. hub.qgis.org/wiki/quantum-gis/API_changes_for_version_20 –  Curlew Feb 15 '13 at 16:34
add comment

1 Answer 1

Seems like the API changes have broken clipper. Try stable QGIS 1.8 instead.

There is no 1.9 release. It's the current development version which is on the road towards 2.0 release. For this new major release the API has been cleaned up and changed thus breaking existing plugins.

share|improve this answer
    
In OSGEO4W, you can downgrade to 1.9.0-174, which was the last release before the API change. Maybe it is safer to start with a clean install. –  Andre Joost Feb 15 '13 at 13:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.