Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have 20 polygons and when I tried to label the layer with the ID numbers only 19 appeared. For some reason my first polygons ID number is not being shown and I dont know why. Am I missing something vitally important? Any help would be brilliant, thanks!!

share|improve this question
    
Did you manage to get this working? –  James S Mar 1 '13 at 7:34

2 Answers 2

Does it work if you label with another data field?

Sometimes Labels are supressed, if there is not enough place for labelling.

share|improve this answer
    
Ive just tried and that doesn't work either. On another note, I dont suppose you know what a green cross means do you? Its just in a polygon where I had added a ring. Thanks for helping! –  emily Feb 16 '13 at 21:23
    
If rings are involved it is likely the ESRI labe engine suppressing it. My alternative workaround is expensive. The maplex extension allows "never remove". –  Brad Nesom Feb 16 '13 at 21:32
    
Not entirely sure what any of that means to be quite honest. Really sorry. –  emily Feb 16 '13 at 21:42
    
I think that arcmap has "place overlapping" option in the label dialog. Try that –  Brad Nesom Feb 16 '13 at 23:01
1  
@emily: I get green crosses in edit mode if a node is used twice in a line or polygon. Can you share a screen copy? –  AndreJ Feb 17 '13 at 6:15

I have found that polygons that do not have valid geometry do not label.

The green cross means that you either have 2 nodes in the same place or possibly you have a self intersection. This could be the reason your layer is not labeling.

To test this, run the Check Geometry Validity tool in the Vector > Geometry Tool menu. You should fix any errors that are found.

Once you have fixed this, your layer should label.

If the geometry is fine and the polygon is still not labeling it could be that the label is not shown as its overlapping with other labels. To test this, on the labeling dialog, choose the advanced tab, then click the Engine Settings button. Tick the Show all Labels (i.e. including colliding labels) tickbox.

This will make sure all labels display even if they overlap.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.