Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have an ArcGIS Server 10.0 for Java running under Red Hat Linux. I would like to be able to publish a Map Document that I have created which has a working Query Layer connecting to Oracle 11g. In ArcMap the layer works as expected. I have installed all the Oracle client software on the ArcGIS Server (the server is actually running Oracle also). I am able to connect via SQL Plus as the ArcGIS server user. I have set all the environment variables to the best of my knowledge. However when I publish the Map Document I get the following in the log

WARNING The Layer:'XXXXXXXX' in Map:'Layers' is invalid. No SDEHOME environment variable set WARNING The Layer:'XXXXXXXX' in Map:'Layers' is invalid. No SDEHOME environment variable set

INFO3 Server Object instance on machine XXXXXXXX is created with errors. The Layer:'XXXXXXX' in Map:'Layers' is invalid. No SDEHOME environment variable set INFO3 Server Object instance on machine XXXXXXXX is created with errors. The Layer:'XXXXXXX' in Map:'Layers' is invalid. No SDEHOME environment variable set

I don't have ArcSDE installed and I thought the idea of Query Layers was that you didn't need it? Very confused and Google didn't turn up much :-(

Any help would be most appreciated.

Regards

Colin

share|improve this question
    
Just checking, but I assume you have done "Enable Enterprise Geodatabase" in your Oracle DB? ArcToolbox... –  awesomo Feb 20 '13 at 2:32
    
I'm not using SDE at all and I'm assuming I don't need to because I'm using a Query Layer? The layer works perfectly in ArcMap but not in ArcGIS Server. I'm pretty new at this so not sure how this works exactly. From what I've read using Query Layers allows you to get round using ArcSDE so I'm not sure why the error message comes up. I'm going to try it on ArcGIS Server for Windows as it wouldn't surprise me if this was a Linux issue. –  mxcolin Feb 20 '13 at 17:02
    
Basically, there's two parts to SDE -- 1. All the system geodatabase tables that enable editing, topology, replication, archiving, networks, or versioning, etc. and then 2. A separate service on the database server for connections (ie port 5151 stuff, you don't use the normal database connection). Esri now says skip part 2 and just use direct connections unless there is a reason to create the SDE 5151 service. –  awesomo Feb 20 '13 at 17:48
    
Here's an article on functionality available with and without geodatabase enabled resources.arcgis.com/en/help/main/10.1/index.html#/… –  awesomo Feb 20 '13 at 17:49
    
What a shock, works in Windows first time :-( –  mxcolin Feb 20 '13 at 17:55
show 2 more comments

1 Answer

All that said above, you should be able to publish a service with data from Oracle -- which I see you just did in Windows. Anyway, you may have already done this -- but try reviewing this section in the help Making_your_data_accessible_to_ArcGIS_Server. Obviously, there is a connection problem of your linux server finding the data.

share|improve this answer
    
Also, note I'm on 10.0 not 10.1 which might be the issue? –  mxcolin Feb 20 '13 at 18:29
    
I'm following all of what is being said here but no luck. I wonder if it is related to the 32 bit vs 64 bit versions of the Oracle client software. –  mxcolin Feb 20 '13 at 18:36
    
After much searching I found this support.esri.com/en/knowledgebase/techarticles/detail/35319 –  mxcolin Feb 20 '13 at 19:09
    
Did this fix the problem? –  awesomo Feb 20 '13 at 20:05
    
So this has helped. By installing the 32 bit Oracle Client drivers the errors go away. The last message in the log is INFO3 Beginning of layer draw: XXXXXXXX however it seems to be taking an awful long time to draw the layer. I will mess around with the layer and see if I can fix it. This article was the golden nugget however. –  mxcolin Feb 20 '13 at 22:00
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.