Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I mainly use the QGis Master (nightly build) for my Debian Linux and I'm quite happy with it. But for educational and demonstration purposes, I now have to work with the Stable(1.8) version.

How can I run a stable QGis 1.8 version in a way that it won't interfere with my other QGis build? The ideal solution will be to run everything just from a folder. This is possible for Windows (QGis on a Stick), but I haven't found any way to do this on Linux systems. I don't want to use any live-distributions or whole Operating Systems.

I tried to compile QGis stable as shown here, but if I try to run it crashes saying:

Warning: !!! prefix path was requested, but it is not valid - we do not run from installed path !!!
Segmentation Fault

Most likely it tries to read the configuration files from my .qgis config folder in the home-directory and fails because it can't work with the 1.9dev configurations and prefixes.

How can I work around this?

share|improve this question
    
PLease can you expand on this process. I'm a relative newcomer to Ubuntu and the language is still a bit Greek to me. I was running 1.8 and upgraded to 1.9.0 hoping the save issues when you have an OSM map in the project would disappear. They have as I have discovered you cannot load OSM or Google Maps at all. Now I'm stuck as I rely heavily on the available satellite data. Please assume I'm an idiot and know nothing and put it as: 1. Switch on PC, 2. Make sure eyes are open, 3. etc... Thanks in advance. Josh –  jhza Jun 24 '13 at 9:34
    
The safest way to install both versions of QGIS is to install an oracle virtual box with Ubuntu as OS and the second version of QGIS. Both are running independently from each other, but can use the same data by shared folders. –  Andre Joost Jun 24 '13 at 9:40

1 Answer 1

up vote 7 down vote accepted

Install your QGIS 1.8 build to a directory in your home directory. You should be able to run it from there. If you get a prefix path error, try setting the following (assumes my install is in qgis_1.8 in my home dir):

export LD_LIBRARY_PATH=/home/gsherman/qgis_1.8/lib
export QGIS_PREFIX_PATH=/home/gsherman/qgis_1.8

You can check to see which libs the 1.8 version is referencing using:

ldd /home/gsherman/qgis_1.8/bin/qgis
share|improve this answer
    
thanks for commenting and posting the export-comments. However i still have problems. I downloaded the 1.8 source, extracted it into a new folder, compiled it in a created build folder after calling "cmake ..". I now have an output folder and if i try to run the qgis bin in a terminal (exporting paths before), i still get a segmentation fault: **** VERSION 10800 Warning: !!! prefix path was requested, but it is not valid - we do not run from installed path !!! Segmentation fault –  Curlew Mar 2 '13 at 12:31
2  
Did you do a make install and try to run it from the installed directory? If not, use ccmake .. to set the CMAKE_INSTALL_PREFIX to a path in your home directory (e.g. /home/gsherman/qgis_1.8), then do the install. –  gsherman Mar 2 '13 at 15:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.