Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

This question already has an answer here:

I'm using OpenLayers and OpenGeo Suite with WMS requests.The tiles load fine, but when I try to load a getFeatureInfo I get a cross domain error. I read about including crossdomain.xml in the Geoserver folder structure but I'm not sure where that is on OpenGeo Suite and couldn't get it to work.

I've also read about setting up a proxy but don't completely understand it. How would I set that up on IIS?

share|improve this question
    
I read those questions but was wondering how to set up the proxy on IIS? Or how to get crossdomain.xml working? –  bl8rchk Feb 20 '13 at 13:25
add comment

marked as duplicate by iant, Devdatta Tengshe, MappaGnosis, Aragon, R.K. Mar 5 '13 at 9:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

I did a lot more research on this and finally got it to work. The Geoserver Proxy Plugin didn't work at all and a lot of the proxy scripts I found were python or cgi, which wouldn't work for me either. I ended up setting up application request routing on my IIS server by following this tutorial: http://www.iisadmin.co.uk/?p=326&page=2

Just follow the instructions in the website.. you have to install a software (ARRv2_setup_x86_en-us.EXE file)... Just search for that in google and download according to your OS spec..Again just follow the website instructions.

After the installation just follow the below mentioned instruction..

I had to change the URL Rewrite rules. The pattern I used is ^geoserver/(.*) and the Rewrite URL is

**http://localhost:8080/geoserver/{R:1}**. 

and apply the rules

Works like a charm!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.