Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to add the political boundaries baselayer from http://www.cec.org/Page.asp?PageID=924&ContentID=2336 and then on top add points where I gathered coordinates from Google Earth (using a delimited text layer). I can see both layers in QGIS but my points are not in the right location and I have to zoom in way too close to be able to see them. It seems to be an issue of scale or projection or something. Im new to QGIS and GIS in general, what things can I try to try and make these layers fit better.

share|improve this question
    
@BlankUsername I figured it out by saving the layer in its new CRS and reloading the newly saved layer. However, now some of points are just slightly off. For example I have several points just off land in the ocean! Any ideas about this. –  user15399 Feb 21 '13 at 0:25
    
I have the same problem for some of the northern locations. Maybe the proposed solution under edit by Andre Joost works. –  BlankUsername Feb 21 '13 at 9:14
add comment

2 Answers 2

Problem is that WGS84 regards Eastern longitudes as positive. So you have to insert a - before every value in your last column. You will get this result with boundaries in EPSG:2163 and points in EPSG:4326:

enter image description here

EDIT

I also get some of the points displaced in the ocean, but e.g. Corvallis looks right. Can you save the data in Google Earth as kml? You can add data in that format directly in QGIS.

For example, I get this for Heekletooth Mountain:

        <longitude>-122.3672942081475</longitude>
        <latitude>43.74097955857287</latitude>
share|improve this answer
add comment

I think the problem is due to a mismatch in the coordinate reference system used. The base layer you use has EPSG:2163 (US National Atlas Equal Area). While I think the Google Earth file uses EPSG:4326 (WGS84), but I'm not sure about this as I have never used Google Earth files. What you can do is right-click on the layer and select "Set Layer CRS" in order to change the layers such that they correspond.

If I'm wrong I am sure a more experienced user will correct me.

EDIT

I got a solution, although with minor errors, by re-projecting the shape-file to EPSG:4326 (see here for an explanation) and inserting a minus in front of the longitude values in the csv-file. Method is similar to the answer by Andre Joost. Encounter the same problem with some points being a little off.

share|improve this answer
    
I tried to 'right-click on the layer and select "Set Layer CRS" to match the coordinate reference systems of the layers but something changed, the layers still look the same. Any other ideas? @BlankUsername –  fawnlily Feb 20 '13 at 21:22
    
No I don't have any other ideas. Do you have a link to the text-file maybe? I can try to replicate the problem and see how to solve it. –  BlankUsername Feb 20 '13 at 21:26
    
here is the textfile. let me know if it doesn't work. txtup.co/i6f7U –  fawnlily Feb 20 '13 at 21:56
    
Are these locations correct? –  BlankUsername Feb 20 '13 at 23:00
    
Set Porject properties, enable on the fly projections, change crs in properties of the layer. –  Gerald Feb 21 '13 at 9:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.