Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to use the i.landsat.toar tool on L7 bands. I have tried to use both the MTL and MTLold, but no matter what I try, it returns "Failed to identify satellite." What am I doing wrong?

share|improve this question
    
Can you show the settings you have in the metadata tab by inserting a screen shot here, or you might be able to highlight and copy the command text at the bottom of the dialog window which is created by your selections. –  Willy Feb 24 '13 at 2:18
    
There have been recent fixes, which version of GRASS GIS are you using? –  markusN Feb 24 '13 at 9:58
    
(Sun Feb 24 09:37:15 2013) i.landsat.toar input_prefix=LE71710822012330ASN00 output_prefix=LE71710822012330ASN00_toar metfile=G:\South Africa\Data\2012\171\LE71710822012330ASN00\LE71710822012330ASN00_MTL.txt sensor=tm7 method=corrected WARNING: Unable to recognize satellite platform [0] ERROR: Failed to identify satellite (Sun Feb 24 09:37:15 2013) Command finished (0 sec) (Sun Feb 24 09:48:27 2013) –  Eric Beal Feb 24 '13 at 14:49
    
This is the output that I received in the command output. I am using GRASS 6.4.3RCD on windows. I'm wondering about the 'prefix' option; I assume this is the file name excluding the band name? –  Eric Beal Feb 24 '13 at 15:15

1 Answer 1

One thing I check explicitly for L5 is that the date of acquisition in the mtl/txt file matches the date of the file to be processed. You have to be aware of the naming convention of the files to do this.

I don't use a standard version of grass, but I expect the module should be the same for you, see this image

enter image description here

Also I just ran a Landsat 7 scene from 1999. For simplicity I treated it as Landsat 5, changing the 61 band to 6. I note that toar would not process that unless I used the mtlold.txt file which was included with scene, which I had only pulled from USGS yesterday. In that case I got the error:

ERROR: Unknown production date (defined by 'product_date')

The successful command was:

i.landsat.toar -t --verbose input_prefix=7_92811999348_ output_prefix=7_92811999348_toar metfile=E:\GIS_mega\7TM+ \Walgett_9281\LE70920811999348SGS01\LE70920811999348SGS01_MTLold.txt method=dos3

note the verbose option to give you some feedback.

share|improve this answer
    
i.landsat.toar has now been updated in GRASS GIS 6 and 7 to deal better with the various metadata. –  markusN Oct 17 '13 at 20:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.