Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am importing tracks from my GPS using the GPS Tool in QGIS. I check the layer CRS and it shows WGS 84 but when I try and view the layer in my project which has a CRS of EPSG:2193 the coordinates are still lat and log (i.e. native WGS84).

I have the same data on another computer and that works fine. I have compared all the setting that I can think of (Project Properties and Setting->Options) between the two system and all the ones I looked at are the same so far as I can tell.

In particular I have made sure that "settings->options->CRS->'on the fly projection' is checked.

I am pretty sure that I have had this issue before but can't remember how I solved it.

What setting do I need to get QGIS to automatically convert the wgs84 layer to project projection? Alternatively what setting might I have inadvertently turned on that might have broken this?

later: I worked through the various things that people suggested (thanks very for the suggestions BTW) I and still could not figure out what the problem was so I then started from scratch again and now everything works as expected. Sigh...

I have been in IT long enough to know that when things just don't work as they should cycling power (or the software equivalent there of) should be tried before shouting "HELP!"

not sure of the etiquette here -- should I mark this as answered?

share|improve this question
2  
It is a good practice to accept one answer. Otherwise the question will return automatically. Besides, your reputation will rise when you are known as accepting answers, giving you a better start point for future questions, allowing you to insert images and so on. –  AndreJ Feb 25 '13 at 5:17

3 Answers 3

up vote 6 down vote accepted

To get the GPX data in other CRS, simply rightclick on the layer -> Save As ... to a shapefile in the projection you want, and add that layer to the canvas.

What might be puzzling you is that in attribute table, coordinates of waypoints still are in lat/lon. If you want projected coordinates in the attribute table, click on the yellow pen to make the layer editable, open the attribute table, and select field calculator (icon bottom right). Create a new field of type real, and select Geometry -> $X for value. Same for $y.

share|improve this answer

When you import GPS data, it will be in WGS84 Lat long. You need to project the data to your required Coordinate system to actually change the coordinate values.

To do this, have a look at this tutorial:Working with Projections in QGIS

share|improve this answer

Since you have enabled on-the-fly projection. Check the crs in which the layers get projected to. Maybe WGS84 is set for on-the-fly and every layer gets projected to that.

you have said that you checked "settings->options->CRS->'on the fly projection", configure the "always start new project with this crs" option and also check the "settings->project properties->crs" and select your project crs there to make it default.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.