Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am using the interoperability extension and building spatial ETL tools, but I can't seem to specify the output location of the ETL tool so it's impossible to use this dynamically.

Has anyone figured out how to do this?

share|improve this question
add comment

2 Answers 2

Data Interoperability Extension 10 Service Pack 1- fixes this issue

http://resources.arcgis.com/content/patches-and-service-packs?fa=viewPatch&PID=83&MetaID=1721

NIM058671 - Cannot specify Output Dataset for the Quick Export tool when it is in a model.
NIM058766 - Cannot specify Input Dataset for the Quick Import tool when it is in a model.
NIM058645 - Data Interoperability is unable to export to the Adobe Geospatial PDF file format.
NIM058646 - FME Workbench is missing some transformers.
NIM057999 - Optional Published Parameters for Spatial ETL Tools do not behave like “optional” parameters.
share|improve this answer
add comment

When creating the Spatial ETL Tool in Workbench make sure that the Destination is Purple in colour, this will mean it is set to publish the output location.

!shows the Toolbox view of the output location1

Once done then in the model that calls the Spatial ETL Tool you can identify the output location as a parameter and then it is able to be set as any model parameter.

!Model Window showing Parameter1

share|improve this answer
    
Turns out that the issue is not that the output is not available to model builder, but it is not available as a variable in model builder... so I wrote a python script to wrap around the ETL script so that I can define the output location in another model.. (ouch) –  GuidoS Jan 25 '11 at 15:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.