Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm not sure what I'm doing wrong.

I have Windows 2012 Server x64 with SQL Server 2012.

I'm also using IIS 8 as a web server on the same machine.

I've installed ArcGIS for Server 10.1 SP1 and ArcSDE 10.1 both on the same server.

I've also installed the Web Adapter 10.1 SP1.

I configured the Web Adapter's GIS Server URL to MyServer:6080

The Web Adapter returned:

Status: The following GIS servers are registered to your Web Adaptor

MyServer

The firewall on the server is currently off.

Port 80 on the router has been forwarded.

I want to be able to access the rest services off network via

External IP/arcgis/rest/services

Do I need to set certain settings in IIS for the Web Adapater?

What am I missing?

share|improve this question
1  
What do you see in ArcGIS Server Manager when you go to Site>Web Adaptor? –  Kirk Kuykendall Mar 1 '13 at 5:17
    
I see my Machine Name, URL, and Administrative Access for example MyServer, MyServer/arcgis, Enabled –  ian Mar 1 '13 at 17:14
add comment

1 Answer

up vote 2 down vote accepted

It looks like your Web-Adaptor may be resolving only to your machines local DNS name, in your example case 'MyServer' versus what name/ip you would potentially connect to it as from another machine.

So in this case you need to make sure both your points can resolve to name/ip so that you can get to them via the URL-ReWriting that the Web-Adaptor does to access to back end port.

share|improve this answer
    
I might now have been specific enough. When I first configured the Web Adapter, for the GIS Server URL, I entered http://(Internal Server's IP):6080 and it came back saying the PC name of the server. Am I using the correct IP? –  ian Feb 28 '13 at 21:55
    
Can I simply go to /arcgis/webadaptor and reconfigure the web adaptor from there? Or do I need to uninstall it and reinstall? –  ian Feb 28 '13 at 22:00
    
I haven't been back to 10.1 enough to be sure. Try going through from the external connection and ping through to that IP address and make sure you are getting to it, and then try hitting just the default web-page for IIS to make sure you are seeing port 80. –  D.E.Wright Mar 1 '13 at 0:22
    
You can reconfigure your web adapter with the external ip or registered domain for the same. Go through start button web adapter –  Brad Nesom Mar 1 '13 at 3:21
1  
What do you mean by start button web adaptor? –  ian Mar 1 '13 at 5:48
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.