Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I'm attempting to clear out the parameters from my model so that the parameter locations don't show up in the tool when launched from ArcToolbox.

ESRI's resource center has a couple of sentences about clearing parameters, but not how to actually do it.

enter image description here

ESRI's attempt at explaining how to clear out the parameters

Does anyone know the steps to clear the parameters of a model built inside Model Builder for ArcMap?

share|improve this question
    
Are you trying to remove the parameter input box, or have them show up but not have any pre-defined contents? –  Jay Guarneri Mar 1 '13 at 0:18

1 Answer 1

up vote 3 down vote accepted

When you are building your model just don't assign a data source to it. Leave it blank. If you need to reset the model just click on the "Validate" button on the model builder toolbar (it's a checkmark) that should reset anything that was holding over from a previous run.

share|improve this answer
    
+1 But at the same time having a value there let's you provide a default which can assist your user. –  PolyGeo Mar 1 '13 at 1:09
    
Got it. I just cleared out the first Parameter, and, subsequently, the Intermediate data cleared as well. I had the manually clear out the remaining parameters (but now my Field Maps for both of my Spatial Join operations are empty even when the source is set for the Input when running the tool :( Thanks for the answer though. It solved the original problem mentioned. –  geominded Mar 1 '13 at 13:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.