Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

i want to make r.sim.water (hydrological modelling) in Grass Gis, and this ERROR: nwalk (7000001) > maxw (7000000)! always appears, any ideas how to solve it?

number of cells of dem is below 7000000.

share|improve this question

closed as too localized by vinayan, whuber Mar 27 '13 at 19:52

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer 1

I am not really familiar with this function. But a quick glance at the grass manual for r.sim.water, the parameter nwalk is defined as,

nwalk=integer
Number of walkers, default is twice the no. of cells

It also says, under the heading Error Messages,

If the module fails with
ERROR: nwalk (7000001) > maxw (7000000)!
then a lower nwalk parameter value has to be selected.

so try a lower value of nwalk.

share|improve this answer
    
i tried this before i posted comment, it didn´t work :) –  Lucia Mar 1 '13 at 9:46
    
How was the error message then? –  markusN Mar 5 '13 at 7:18
    
it was still the same, i tried working in another pc and finally it worked –  Lucia Mar 27 '13 at 15:02
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.