Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I stumbled across a gotach while installing mod_fastcgi on MacOs 10.8 (mountain Lion) -- there is a bug in 10.8 in the apache build env which breaks the install instructions here: http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial

The fix is to put a symlink

 sudo ln -s /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/ /Applications/Xcode.app/Contents/Developer/Toolchains/OSX10.8.xctoolchain

as documented here:

http://apple.stackexchange.com/questions/58186/how-to-compile-mod-wsgi-mod-fastcgi-etc-on-mountain-lion-by-fixing-apxserror

It would be good to get this noted in the docs...

Should I open standard bug report or is there a better way to report 'problems' with a document?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

If your issue is related to the MacOS version, you could contact William Kyngesburye directly. He is the maintainer of KyngChaos.

Reporting bugs in hub.qgis.org is nethertheless a good choice, helping others with similar problems.

share|improve this answer
    
Thanks for the suggestion but it isn't an issue with the packaging but with the tutorial. The instructions as given don't work with current versions of MacOS because of a bug apple introduced with there apache source configuration. The tutorial has a MacOS specific section and that is what I would like to see updated. –  Russell Fulton Mar 2 '13 at 22:45
    
Doh! It's a wiki -- I can put the edits in myself! Silly me. Just doing so and fixing a couple of minor mistakes in the as well. –  Russell Fulton Mar 3 '13 at 1:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.