Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I want to georeference a jpg file (map) with QGIS 1.8.0 on a Windows 7 (64 bit) machine.

The georeference window opens, but the map is not visible. When converting the jpg file into a tif file (e.g. with gimp) everything works. I tried it with several files. Always the same: The tif files are visible and can easily be georeferenced, while the jpg-files are not visible in the georeference window.

Any ideas?

Thanks for answers, Ulli

share|improve this question
2  
Can you check in GIMP if the jpg is a jpeg2000, or has a special compression method? –  AndreJ Mar 5 '13 at 13:14

1 Answer 1

When you save your JPEG in GIMP, expand the 'Advanced Options' when the 'Export as JPEG' dialog box comes up. Un-check the 'Progressive' box and then click 'Export'. Your JPEG is then readable in QGIS.

"Progressive" changes the encoding to display the image at increasingly higher quality levels until the image is fully loaded. QGIS is expecting standard encoding. Progressive encoding appears to be on by default in GIMP (at least in GIMP 2 - I can't remember for earlier versions).

share|improve this answer
    
It works after unchecking the "progressive" box in the export-dialog of GIMP. I expected the problem to be in QGIS and not in GIMP...Many thanks, Ulli –  Ulli Mar 6 '13 at 12:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.