Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I was wondering if anyone has used the LAS2OGR tool? I heard about this from a previous post. The webpage gives the usage: http://www.liblas.org/utilities/las2ogr.html

las2ogr -i mydata.las -o points.shp -f "ESRI Shapefile"

But I am wondering what I run it in? I am on a Windows & box with FWTools 2.4.7 and it is coming up as an unrecognized tool. When I open OSG4W (gdal 1.9.2 released 2012/10/08) las2ogr is not listed in the tool set. Where should I be accessing this from? Do I need to download a specific .exe or .dll and save it to the GDAL folder?

Any help would be appreciated.

Thanks...

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I think you just have to install liblas from the Commandline_Utilities in the osgeo4w installer:

installing liblas from osgeo4w installer

Once that's done, it should be available via the osgeo4w terminal: las2ogr in osgeo4w terminal

share|improve this answer
    
Thank you, I have done this now, but when I try to access las2ogr, it comes up as: Error: missing input paremeters –  Ryan Garnett Mar 5 '13 at 19:48
    
@ryangarnett Can you see las2ogr in the list of available tools inside the osgeo4w terminal? –  SaultDon Mar 5 '13 at 19:53
    
Yes I can, that is the odd thing. I read that I need to put in liblas, when I do, a new window opens, its: Administrator: libLAS OSGeo4W Shell –  Ryan Garnett Mar 5 '13 at 20:13
1  
@ryangarnett That is strange. I didn't have to add any env variables. The las2ogr.exe is in my OSGeo4W\bin folder. That bin folder gets added to the %PATH% every time osgeo4w is ran so it should be finding it. What is the output from las2ogr -h? Does it give you a list of options? –  SaultDon Mar 5 '13 at 20:22
1  
...s actually working. You just need to enter parameters now like the input/output file and -f for format like you have originally. –  SaultDon Mar 5 '13 at 20:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.