Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently my QGIS started refusing to load SIP module, from day to day without any significant changes in the system (I'm on Windows7 x64). Message thrown at startup:

Nie można wczytać modułu SIP. (Couldn't load SIP module)
Wsparcie dla Pythona zostanie wyłączone. (Python support will be disabled)

Traceback (most recent call last):
  File "", line 1, in 
ImportError: cannot import name wrapinstance

Wersja Pythona: (Python version)
2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]

Wersja QGIS: (QGIS version)
1.8.0-Lisboa 'Lisboa', f440b60

Lokalizacja Pythona: (Python location)
['C:/PROGRAMS/Geodesy/OSGeo4Win/apps/qgis/./python', 'C:/Users/Muciek/.qgis//python', 'C:/Users/Muciek/.qgis//python/plugins', 'C:/PROGRAMS/Geodesy/OSGeo4Win/apps/qgis/./python/plugins', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\qgis\\python', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib', 'C:\\Windows\\system32\\python27.zip', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\DLLs', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\plat-win', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\lib-tk', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\qgis\\bin', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\site-packages', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\site-packages\\PIL', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\site-packages\\win32', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\site-packages\\win32\\lib', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\site-packages\\Pythonwin', 'C:\\PROGRAMS\\Geodesy\\OSGeo4Win\\apps\\python27\\lib\\site-packages\\wx-2.8-msw-unicode']

I tried reinstalling various versions of QGIS (1.7 - 1.9) and manipulated with system Path and PYTHONPATH both with no result.

QGIS starts perfectly on different user account (without administration rights). It means that it may be a problem with sone software installed but still I have no idea what could it be.

Any help or suggestion would be appreciated, thanks in advance.

share|improve this question
1  
Ok, I managed to solve the case. The problem was in C:\Users\<Username>\.qgis\python\plugins\sip After removing this folder everything got back to normal. Regards. – MMuc Mar 12 '13 at 6:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.