Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I have a line vector layer selected, editing is on, I select one vector (a dozen points) with the node select tool so the vertices are red squares.

  1. the cut icon is greyed out, command/X does nothing, delete part isn't greyed out but does nothing; so I can't cut/copy/delete it

  2. I select a vertex so its square turns to blue, then hit the delete key - nothing happens. Remember, a PC delete key is forward delete, back delete is the backspace key; a Mac has no forward delete, the delete key is a back delete; is this the problem or is it related to 1.?

  3. I can't select more than one vector by holding down the control key (or shift or command - I've tried everything I can think of) - when I click on the second vector the first is deselected. Again, is this a Mac-only problem?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Using the node tool, when you select a node it turns blue. Then, hold the [fn] key and then press [delete]. That will emulate the [Delete] key on Windoxs/Unix. I just tested this on 1.8 on a MacBook Pro.

EDIT: For point #3, you can select multiple vectors (also called features) with one of the "Select Features" tools. Here is a picture of the options:

enter image description here

To pick multiple features you will want one of the bottom four tools. Note that if you are using the top tool (Select Single Feature) it only lets you pick one at a time.

share|improve this answer
    
Good - one thing works! Many thanks. But no, in 3 I meant vector, to merge two vectors (unsplit them). –  johnsankey Mar 13 '13 at 14:41
    
Now I understand! I edited the answer to address that part of your question. –  katahdin Mar 13 '13 at 14:51
    
Looks great, except that I can't find any of those select features at all... –  johnsankey Mar 13 '13 at 15:39
    
FOund them - under View! (not edit or vector or ...) And now the cut copy etc. are active, so 1 & 3 are answered too. Many thanks, katahdin. –  johnsankey Mar 13 '13 at 15:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.