Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

I am trying to import a .DGN with Grass v.in.ogr in QGIS. I am able to import the DGN perfectly, but I would like to filter the elements using the WHERE option. From searching, reading and testing I think it should be running correct, but it is erroring out. Any help would be appreciated. The attribute column holding the information I would like to Filter on is called Level and it is an Integer. I want to filter it on a value of 1 (see attached image).v.in.ogr filer

share|improve this question
    
I haven't used this tool, but maybe try putting Level in quotes: 'Level' = 1 or possibly "Level" = 1 or even putting the 1 in single quotes. –  Fezter Mar 15 '13 at 2:01
    
Level = 1 as in your screenshot works for me(qgis 1.8) –  vinayan Mar 15 '13 at 2:41
    
I have tried the "" and ''. I am using 1.8.0 for Windows. Vinaya, what data format are you importing? Have you tried it with a .DGN. I am concerned that the you can not filter based on an Autocad format. –  Ryan Garnett Mar 15 '13 at 5:58
    
i tried with a .dgn file –  vinayan Mar 15 '13 at 7:00
    
are you getting "Unable to open data source..Finished with error" in the output window? –  vinayan Mar 15 '13 at 7:09
show 2 more comments

1 Answer

ogr cannot read Microstation DGN files if the versions starting from 8.0. You could be using a newer version dgn file.

from the gdal ogr website,

Microstation DGN

Microstation DGN files from Microstation versions predating version 8.0 are supported for reading. The entire file is represented as one layer (named "elements").

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.