Take the 2-minute tour ×
Geographic Information Systems Stack Exchange is a question and answer site for cartographers, geographers and GIS professionals. It's 100% free, no registration required.

The following error message shows during an attempt to open geoserver url...

"HTTP ERROR: 404 NOT_FOUND RequestURI=/geoserver"

Note: I have restared the Start/Stop .bat files several times & also restarted the PC.

share|improve this question
1  
What do you see in the Geoserver Logs? –  Devdatta Tengshe Mar 15 '13 at 5:52
    
I can not open geoserver log(wrapper.log) file size is nearly 861mb...I replaced the log file with a new one... –  Sandipan Saha Mar 15 '13 at 6:24
    
Are you on a Windows on Linux Environment? If your running .bat files, Windows. –  Mark C Aug 23 '13 at 10:13
add comment

4 Answers

up vote 3 down vote accepted

Assuming you are on windows (you mention .bat), you can do a number of things:

  1. Check the Services in windows Control Panel --> Administrative --> Services. Look for the Geoserver entry and make sure it is actually running and not disabled or stopped. You can start it from here and set it to enabled as well

  2. Make sure you are navigating correctly to the right url. It should be

    http://localhost:8080/geoserver

or whatever port you nominated when you installed Geoserver with the windows installer

  1. Make sure no other Http Service is using the same port. First in, best dressed and the services start later and try and use that same port will fail. Development Computers fall prone to this. If so, edit you Geoserver config file at *$GEOSERVER_HOME/etc/jetty.xml* and change the port in there. Make sure Geoserver is not running then use the new port in your http request after restarting Geoserver.
share|improve this answer
add comment

I've had the same issue on windows.
The start up batch file would not work for me. My solution was to open a cmd.exe window running as a Administrator and navigate to the batch files,

>cd "C:\Program Files (x86)\GeoServer 2.4.5\bin

and run this

>startup.bat

from the prompt.

share|improve this answer
add comment

Always run startup.bat from cmd prompt as an administrator. It should work.

share|improve this answer
add comment

I got the same problem in Windows 7 and GeoServer. But, in my case, the problem was related to using Tomcat 8! I uninstalled the 8 version, installed Tomcat 7 and everything went OK. Check your Tomcat version.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.